Install Discord on Qubes

Hey guys :wave:t4: , I spent many hours trying to install Discord but I can’t I got all the times an error I tried with the .deb file on a StandaloneVm based on debian 11 but impossible to install the missing dependency, I tried to run sudo apt install -f just after sudo dpkg -i "discord".deb and then again sudo dpkg -i " discord".deb but nothing happens It just remove my discord with missing dependencies.
I tried with flatpak installed on debian-11-minimal template, I was able to install flatpak but flathub don’t want to be installed I got Temporary failure in name resolution I tried also an AppImage on a AppVm but also impossible to launch it.

If anyone have an idea how I can install discord, Thanks

try using fedora?
sudo dnf install$(rpm -E %fedora).noarch.rpm && sudo dnf update && sudo dnf install discord

I’ve once installing snapd from dom0 terminal (qvm-run), and it takes me sometime to realize that I haven’t install qubes-core-agent-networking.

I believe it’s just an network error, not installed apps / network related.

With Fedora did you install discord on a StandaloneVM or AppVm ?

Install it on templatevm in the past, haven’t use discord for long time, but i think it would work in both standalone / template, don’t install it on appvm since it didn’t persist.

Or you could try the appimage, it would fine too.

Try this:
Fedora: > sudo dnf install snapd

Debian: > sudo apt install snapd

Then: > sudo snap install discord