Instalation trouble: Unknown error

Hello. After getting over some troubles, I finally could get the installer to display something. It was just giving me a black screen, but I was able to fix it by changing the boot mode to legacy boot instead of UEFI and entering some kernel parameters as indicated in the documentation. To be more specific,

 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

However, there is one last thing bothering my installation…
Everything works perfectly normal, but when I click to start the installation it starts to write on the [empty] disk, until it stops on some file installation.
It is on /dev/mapper/qubes_dom0_root--pool

Since I’m using a Nvidia gpu, it might be the problem.
Oh, I don’t know if it has something to do with it, but before the installer loads the GUI there are 2 error messages:

Dracut-pre-udev[641]: modprobe: ERROR: could not insert 'floppy' no such device


Not asking for VNC because we don’t have a network

Something like that.

Anyone can help?


Did you try this?

it doesn’t have any related to gpu thing, i believe it’s storage issue, try using automatic and use encrypt drive when installing, delete and reclaim all space is a must.

I have wiped the disk before installing Qubes, and only did the automatic partitioning. BTW, what is the partition configuration I should do to partition the disk correctly?

I think it might be helpful. Last time I read it I just tried the grub and EFI configuration, but I think this part will be more useful to me.

Well, same error. The installation is normal until it starts

Creating ext4 on /dev/mapper/qubes_dom0-root--pool

After that the unknown error screen pops up. The only thing I have seen in the documentation is that it happens when you try to install in a non empty disk. But I’m wiping the disk every time before booting the installer.

So, any idea guys?

Sorry to hear. I remember I had to pull it out and wipe it on another machine (as I can recall it was with diskpart), as well as creating new installation medium on a different usb stick with Rufus under Windows. No idea why it worked but can confirm it happened more than ones, since I experimented with installing or not sys-usbs and other options, in a row until was satisfied…

Nope. Didn’t work ether. Even wiping the partition table was not enough to solve it. But if it wasn’t that, what else could be???

Out of ideas! Faulty HDD/SSD?

Finally!!! After about 9 times I was able to install it!

I was trying the manual installation all the times, but since it was not working, I decided to go for the manual installation. I mostly used the commands indicated on the custum install documentation.

First, I switched to the tty2 of the installer by pressing ctrl+alt+F2, and wiped up the whole disk:

dd if=/dev/zero of=/dev/sda bs=1M status=progress && sync

Then, I created a MBR partition table and two partitions:

fdisk /dev/sda
Welcome to fdisk (util-linux 2.34).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Command (m for help): o
Created a new DOS disklabel with disk identifier 0x37845dec.
Command (m for help): n
Partition type
   p   primary (0 primary, 0 extended, 4 free)
   e   extended (container for logical partitions)
Select (default p):p
Partition number (1-4, default 1):1
First sector (2048-268435455, default 2048):2048
Last sector, +sectors or +size{K,M,G,T,P} (2048-268435455, default 268435455):+1024M
Created a new partition 1 of type 'Linux' and of size 1 GiB.

1GiB for the sda1 (that will be the boot partition)

Command (m for help): n
Partition type
   p   primary (0 primary, 0 extended, 4 free)
   e   extended (container for logical partitions)
Select (default p):p
Partition number (2-4, default 2):2
First sector (2099200-268435455, default 2099200):2099200
Last sector, +sectors or +size{K,M,G,T,P} (2099200-268435455, default 268435455):268435455
Created a new partition 2 of type 'Linux' and of size 126.99 GiB.

After that, I’ve created a LUKS encrypted volume on sda2:

cryptsetup -v --hash sha512 --cipher aes-xts-plain64 --key-size 512 --use-random --iter-time 10000 --verify-passphrase luksFormat /dev/sda2

Opened it

cryptsetup open /dev/sda2 luks

And created the logical volumes

 pvcreate /dev/mapper/luks
 vgcreate qubes_dom0 /dev/mapper/luks
 lvcreate -n swap -L 10G qubes_dom0
 lvcreate -T -l +100%FREE qubes_dom0/pool00
 lvcreate -V1G -T qubes_dom0/pool00 -n root
 lvextend -L <size_of_pool00> /dev/qubes_dom0/root

Then, switched back to tty6 pressing ctrl+alt+F6

So far, pretty much the same as the documentation says. But when I went to the “personalized installation” option, it was not identifying the changes on the disk.

After some fighting against this problem, I solved it by entering the Installation destination , Custom and Rescan Disks. After rescanning the disks, I’ve entered the Advanced Custom (Blivet-GUI option.
Then I tried to enter the mounting points on the LVMs, but for some reason it was not allowing me to select a mounting point for the qubes_dom0-root volume, so I deleted it and made another one with the same name using Blivet-GUI.

Tip: when entering the volume name, type the name as root. If you put the name as qubes_dom0-root it is going to output the name as qubes_dom0-qubes_dom0-root. WRONG.

Finally, selected “Done”, and “Begin Installation”, and it went just fine!

So that was my solution.
: )

I will not discard this, since my SSD speed is only 65MB/s. Weird…

1 Like