Initial Setup Help Request - ASUS ROG Strix Scar 16 (G634JZ-XS96)

Noting up front that while I’m relatively tech-savvy, I have no experience with Linux whatsoever. I understand that in the world of Linux, the Qubes learning curve is particularly steep – nonetheless, I’d like to be able to start here.

I’m trying to get Qubes running on my new laptop. My specs are as follows. I believe my hardware is compatible, but if I’ve overlooked something, please let me know.

Processor: 13th Gen Intel® Core™ i9-13980HX
Graphics: NVIDIA® GeForce RTX™ 4080 Laptop GPU
Display: ROG Nebula HDR Display
Memory: 16GB DDR5-4800 SO-DIMM x 2
Storage: 1TB PCIe® 4.0 NVMe™ M.2 Performance SSD
Network Adapter: Intel® Wi-Fi 6E AX210

So far the process has gone like this:

  1. Initially the SDD was undiscoverable by any bootable usb I was creating. I disabled the VMD controller in BIOS to solve this.

  2. On first attempt, Qubes installation froze at network setup. I tried again with an ethernet cable connected which seemed to solve the issue.
    Note: The Qubes installer had rather severe graphical lag – I was getting about 1/5 FPS.

  3. I tried booting into Qubes after installation and arrived at a black screen (sometimes with an immovable mouse pointer, sometimes without). Having noted that this might be an Nvidia issue, I tried booting into failsafe (which to my understanding simply involves choosing “Advanced options for Qubes (with Xen hypervisor)” after Bios spash screen – please correct me if that’s wrong). This changed nothing. I also tried adding a handful of commands (one at a time, though these felt like a shot in the dark as they were recommendations made for different hardware) to the end of the grub line beginning with “multiboot2” as per some threads I found online to no avail.

  4. Noting this for what the data might be worth, though I’m not really sure if this change was a step in the correct direction: I re-enabled the VMD controller in BIOS for shits and giggles, and was able to boot into what I assume is the Qubes OS initial loading screen before login (grey screen, a Q in the center, and a small progress bar at the bottom). The progress bar gets to about 50-75% before hopping to the screen in my screenshot.

Any direction, tips, resources, or advice any of you gurus could provide would be greatly appreciated. I’m able to provide more information, with a little direction, if that will aid in troubleshooting.

Disable VMD.
Try to disable NVIDIA GPU, edit GRUB menu option and add this to the end of module2 line:

nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off


Try to install Qubes OS with kernel-latest, there is separate menu entry in Qubes OS installer for this.

1 Like

Apologies for the delayed reply here – have been dealing with some pressing medical issues.

Installing with kernel-latest fixed the installer lag 100%.

On my first attempt I neglected to add the recommended parameters to the end of the grub module2 line before post install configuration. This allowed me to boot and log into Qubes once, after which my device would try to launch the OS, showing the load screen, and then simply restart before the login screen.

Reinstalling with kernel-latest and then adding nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off between installation and initial boot configuration seems to have solved my issue entirely. The OS seems to be stable now.

Thank you!