Impossible to remove Qubes OS and install another Linux distro?

I booted the computer from Debian installation USB and failed the installation:

the logical volume vm-sys-net-private on qubes_dom0 could not be removed

Luckily it seems to be possible to re-install Qubes OS from another USB. I also tried installing Bodhi Linux but it resulted in the same failure. So am I doomed to use Qubes OS for eternity? Or is it possible to install another distro somehow?

Just zero the drive if you’re done with Qubes and want to install something else.

If it’s a SSD, blkdiscard -f /dev/nvme0 (or whatever the block device is) should wipe everything on that drive (so make sure you want it toast).

If it’s a hard drive, that usually won’t work, so dd if=/dev/zero of=/dev/sda bs=1M or something like that should zero it.

Both need to be run as root.

But if you’re entirely done with Qubes on the volume, just nuke the entire volume and the other installers will work fine. I’m not surprised they’re a bit weirded out by the Qubes disk structure. It’s quite “not normal for Linux installs.” Though I’d have expected them to allow you to erase everything and continue.

1 Like

Thanks. I’ll look into that after my current attempt. I noticed that there is a “make sys-net disposable” option in the installation. So I’m installing Qubes now with that box checked and I hope it means the possibility to remove the logical volume causing problems.

Attempt to…

What exactly are you trying to do? I thought you were saying that you were trying to install another Linux distro “on the iron,” wiping Qubes out entirely. sys-net has nothing to do with that in the slightest, and the difference between a disposable and non-disposable sys-net is that a disposable one won’t remember wireless passwords between boot (as the most user-visible difference).

1 Like

Yes, the idea is to remove everything and install Debian. sys-net was there in the installation error message so I thought maybe the disposable option allows removing it. But as you explained, it does not help. Now I’m trying to find the right command for deleting everything from the hard drive.

“Starting over with a new domain” was suggesed when it was found out that Qubes runs on Xen. I don’t know what that means, any explanations would be very welcomed.

Dont do this.
@jvkloc has already told you what to do.

If it’s a SSD, blkdiscard -f /dev/nvme0 (or whatever the block device is)
Or clean the disk using hdparm

If it’s a hard drive, dd if=/dev/zero of=/dev/sda bs=1M

1 Like

Thank you for the reply @unman . It’s a hard drive I’m trying to clean and install Debian to. I’m still a bit confused about usig sda with the dd - command as I got the following output with lsblk:

user@personal:~$ lsblk
xvda    202:0    1    20G  0 disk
├─xvda1 202:1    1   200M  0 part
├─xvda2 202:2    1     2M  0 part
└─xvda3 202:3    1  19.8G  0 part /
xvdb    202:16   1     2G  0 disk /var/spool/cron
xvdc    202:32   1    10G  0 disk
├─xvdc1 202:33   1     1G  0 part [SWAP]
└─xvdc3 202:35   1     9G  0 part
xvdd    202:48   1 510.7M  1 disk 

so instead of sda there is xvda, xvdb, xvdc and xvdd. Should I use sda anyway?

You can wipe out the begining of your disk in the debian installer, before the partition tool section.
You can switch to another terminal (Ctrl+Alt+F1), then dd if=/dev/zero of=/dev/sda bs=1M count=100.

Regarding which /dev/sd... you probably can can use cfdisk /dev/sda and check it has the right size.

@palainp I suppose that makes Debian installation possible and after installing I can somehow clean the rest of the hard drive? Why not clean it right away?

The command with the count parameter only wipe the begining of the disk which is enough to use the partition tool. Except if you have sensible data during your Qubes usage, you probably don’t have to worry about the remaining of the disk, it will be erased when you’ll use debian.

1 Like

No - you are looking at a qube.
Boot a live usb, identify the real drive in your computer, and run the
command against that, whatever the drive is.

Done. The dd - command suggested by @unman worked with sda replaced with the name found from my system. Thank you all.