Icons in libreoffice

I installed the LibreOffice (in work qube) but the desktop in Qube Work is empty? I looked for the icons in libreoffice folder but cannot find any?
Is this the correct process: downloaded LibreOffice into Work Qube and installed it right there, the installation created “libreoffice” folder where this “libreoffice” resides now. I used the “install” file that came with LibreOffice to install it.
Is there any proper way to install this software?

Just a guess but, you’ve installed to your AppVM as opposed to your TemplateVM?

For more info:

I would instead recommend installing it using your distro’s package manager. I don’t know whether you’re using Fedora, Debian, or something else in this template, and I don’t know the exact package names off the top of my head, but you can use your package manager to search for them (or just search the web for “how to install libreoffice on <your_distro>”).

For example, in a Debian template, I would usually do something like this:

sudo apt install --no-install-recommends libreoffice-calc libreoffice-writer

But I also don’t know which LibreOffice components you want.

Well, I ran the “install” file and it did what it did without my additional input. How do you redirect the install if you get the app in you Download directory?

~/Downloads$ sudo apt install LibreOffice_7.5.0_Linux_x86-64_rpm
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package LibreOffice_7.5.0_Linux_x86-64_rpm

Looking for some package …?

No idea what’s happening here, you are trying to apt install an RPM file? That won’t work w/o :alien:. Furthermore, why are you choosing to download the package as opposed to using the system’s package manager?

Sorry, I guess I did not explore the system enough. I am working on it right now. I’ll be back with some more Qs. Thanks much

So, I went to Fedora template software and clicked some packages to get installed. Now I would like to know where all of those apps are since it does not show in any qube-Applications list?

Did you try adding them to the app menu via the qube setting’s “Applications” tab?

Well, they do not show up in “Applications” tab!? That’s where I looked once I selected and install them. Do I need to create a new Template and then select/install them and then they should show up in “Applications” of that Cube or the Template?

I got this message “failed to execute getDate in dom0” when I ran ‘Refresh Applications’ during restart and shut down of the Qubes.

I’ve never tried this method of installing packages, so I don’t know whether they installed correctly.

After installing the new packages in the template, did you remember to shut down the template and all app qubes based on it?

It doesn’t have to be a new template, no.

Generally speaking you should use the packages that come with the
Templates that provide backing for the qube where you want to use the
Qubes is unusual because the Templates are not network connected, and
use a proxy service to download. Fedora software applications do not
work properly in this configuration. Debian do.
So if you want to install software in to a Fedora template you have to
use the command line dnf tool. There is plenty of help in using this
tool online.

With some software you can do a local install, instead of installing in
the Template. For Libreoffice you have to choose a FlatPak, or Snap, or AppImage.
If you use the stock rpm or deb package, the installation will disappear
when you restart the qube.

All this is explained here

1 Like

:~$ sudo dnf install libreoffice
Unable to detect release version (use ‘–releasever’ to specify release version)
Error: There are no enabled repositories in “/etc/yum.repos.d”, “/etc/yum/repos.d”, “/etc/distro.repos.d”.
:~$ sudo dnf install code::blocks
Unable to detect release version (use ‘–releasever’ to specify release version)
Error: There are no enabled repositories in “/etc/yum.repos.d”, “/etc/yum/repos.d”, “/etc/distro.repos.d”.
Tried to use the above or
the “install” does not install!?

dnf is the tool used for package management in Fedora systems.
You are trying to use this tool in a Debian template (or qube)
This wont work.

On a Debian based system the tool to use is apt
apt install libreoffice will do.
For a useful tool on Debian you can also use aptitude.
This provides a front end that allows you to search and install
packages. It also (and importantly) will show you conflicts and suggest
resolutions - I recommend it for beginners.
You can find simple guides online , like the manual

1 Like

This is a very different story “aptitude”! I looked at the template Fedora36 software believing that’s where the stuff is, so thank you ‘unman’

well, again and again I installed “libreoffice” but nowhere I can find it!?

… I like the Basics where it says: “piece of cake”… :shushing_face:

@DZigler, I believe all the correct steps have been provided to you here (as well as in the documentation), but it sounds like you might accidentally be skipping one of them (maybe even a different one on each attempt) or accidentally inverting the order of some of them. (The order is very important.) It would help us help you if you could start from a clean slate (brand new template and app qube) and write down the exact sequence of steps you perform along the way. Share this list of steps with us, and we might be able to spot where things go awry.

I wonder if you are looking in the wrong place.

Looking back at your original post you seemed to expect that
icons would appear on the desktop. This wont happen automatically.
The reason is that the desktop is controlled by dom0 - you can create
icons there to launch libreoffice in a specific qube,but you have to
do this. In KDE you can drag launchers from the Menu to the desktop.

If you want to make a substantial change to a template it’s often
advisable to clone the template ,and to make changes in the new clone.I
don’t know if you did this.
I’m assuming,although you don’t say so, that you are now working in a
Debian template.
In whatever template you did work in, run aptitude,and search
for libreoffice. - You should see the package with an "i"in the first
column showing it is installed.

Next,check the settings for that template under the Applications tab -
you should see LibreOffice and it’s core programs on the “Available”

Open the settings fora qube that uses that template as it’s template.
If you do not see LibreOffice under Available or Selected on the
Applications tab,select the “Refresh applications” button

It is actually a “piece of cake”! I think I got it, in the “Qube Template Manager” for your Qube(name) you have to change the system from “debian-11” to “fedore-36” and then your Qube(name) you get the (name):software and that’s where all your installed software is!! I already installed some, on the contrary the “Fritzing does not install!?” It tries “Preparing…” but fails!
BUT IT WORKS! Thank you for your 2 last comments, that’s how I got there. :sunglasses: :disguised_face: :face_with_monocle: