I want to create proton vpn Qube

Hellow all.
I’m new to Qubes. I want to use Proton VPN, so I created a separate cube and installed the Proton VPN app, but when I open the app, it says there is a network error. In other people’s questions, it was written that the problem can be solved by using network-manager. I installed “network-manager” and “qubes-firewall” on that cube. However, I don’t know how to use network manager. Not even an icon appears. How can I use proton vpn? Please give me advice. Incidentally, it seems that you can also randomize the MAC address from the network-manager page, so I would like to do that as well.

Describe all your steps to install and use proton vpn app that you’ve tried with all details so someone could point out what did you do wrong.

You don’t need to use the proton’app.
You can’t use the tuto of @solene : Wireguard VPN setup with wireguard.

Or use this tuto for openvpn.

I try this two tutos with protonvpn… :slight_smile:

1 Like

It appears you need to use the app to take advantage of the free option. You can download a wireguard configuration and it will work, but only for one day before you need to download a new configuration.

You just have to select “free server config” and use “create”. Then you download the config’s file.

The config’s file can be use for one year…

1 Like

Is the method you are talking about setting the installed file (for example, Open VPN) from VPN Connections in the WIFI icon option at the top right of the screen? I tried that method before, but I couldn’t use it because sysnet Authentication required and Unlock keying (Default keying) were displayed, and either of them asked for a password even though I didn’t remember setting it. So I installed an app, but it didn’t work either.

If you want to use openvpn (neither for wireguard), don’t touch your sys-net or sys-firewall. Use another qubes and just do like this documentation:

Just follow the documentation to the letter and everything will be fine :wink:
So for wireguard, follow @solene tuto and for openvpn, follow the @taradiddles tuto…

I know some VPN provider have dedicated guides for Qubes OS, mostly because using a VPN App in a service netVM has some challenges. Mostly, when the VPN is enabled and firewall enabled, you have to change the DNS offered to the other qubes through the firewall.


Do you have some exemple of this vpn provider?


Thank you both. I tried it, but it didn’t work. advice please. In the case of OpenVPN, I was embarrassed to say that it failed at the third step of Set up a ProxyVM as a VPN gateway using NetworkManager, Set up your VPN as described in the NetworkManager documentation linked above. I don’t understand what the NetworkManager documentation linke refers to. For WireGuardVPN, download the file wg-jp-FREE-100002.conf from the proton vpn site, go to sys-vpn, and from that template nmcli connection import type wireguard file wg-jp-FREE-100002. conf
but I got an error asking me to add ‘.conf’ at the end of the file. The display icon below appears and says Connect Established vm uplink eth0, but there is no P-marked padlock.

If the above command is what you ran, then you have a space between “wg-jp-FREE-100002.” and “conf”. This would explain the error message.

If you say that the trouble is that if you try to had a new connection for openvpn and you don"t have the option in network-manager, Check that you have install the network-manager-openvpn plugin…
If not try to install it with
sudo apt install network-manager-openvpn
Then, you will have this fonction available in network-manager and just have to import the config’s file .ovpn

Sorry, I wasn’t talking about that, I was talking about the section in @taradiddles tuto. I can’t find the NetworkManager documentation link mentioned there. In any case, I don’t think the network-manager-openvpn plugin is installed. I don’t even know how to install it. I typed sudo apt install network-manager-openvpn in the terminal, but an error occurred.

Sorry, that was a mistake when I wrote the question. The content entered in the terminal has no spaces. I tried it again, but the error still occurred.

Post the whole error message.

In the example file wg-jp-FREE-100002.conf, failed to import wg-jp-FREE-100002.conf:The name of WireGuard config must be a valid interface bame followed by .conf. I got an error code. Also, when I typed sudo apt-get install network-manager-openvpn-gnome, I got an error code like sudo : apt-get : command not found.
Thank you for posting the article

Make the file name shorter, change it to e.g. wg-jp-100002.conf

It’s for debian template. For fedora template it’d be:

sudo dnf install NetworkManager-openvpn-gnome

Yes i remember i had an error like that!

1 Like

Thank you both for helping me solve my problem. After renaming the file to 1.conf, it failed several times for some reason, but after that, I got a code like nmcli connection import type wireguard file 1.conf Connection successfully added.. A padlock mark like the one below will also appear. This time with a P mark! ! Does this mean that the VPN connection was successful? Are VPN connections similarly affected for other VMs?