I can't update debian template

I can’t update debian template. what is a solution?

Tell us what you tried and give the error logs. Without that we can’t help at all.

I tried in dom0: qubesctl --show-output --skip-dom0 --templates state.sls update.qubes-vm
But I couldn’t.
So I tried in Debian template and standalone: apt-get clean && apt-get -y update && apt-get -y dist-upgrade && apt-get clean

Terminal answered

Reading package lists… Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/

It says the error is Permission denied, you need to run the command with sudo

I don’t know if it’s a good idea to dist-upgrade the template.

This usually works for me:
sudo apt update && sudo apt upgrade -y

I tried with sudo. But I couldn’t.

Try this with sudo in front.

My psychic abilities are failing me.
If you want help you have to give a little information.
“But I couldn’t” is wasting your time and ours.
When you try a command and see some output, tell us what it is.

If you used the command in dom0, the output will say - “permission
Run the command with sudo in front - that’s a program that allows you to
run a command as root user.
sudo qubesctl --show-output --skip-dom0 --templates state.sls update.qubes-vm

Better still, use the GUI update tool.