I can't get wyng 04alpha2 working

I’m trying to get wyng backup 04alpha2 working. Maybe I’m misunderstanding how to use it.

I git cloned the project in a disposable VM, git checkout'd to 04alpha2, and then copied to dom0 the Python executable and the other scripts in the misc directory.

Then, in dom0, I tried running wyng:

[user@dom0 wyng-backup]$ ./wyng --local=myvg/mypool --dest=qubes://admin-backups/media/veracrypt1/backups/wyng/ --encrypt=xchacha20-poly1305 --verbose arch-init
ERROR: wyng is already running.

But wyng isn’t running according to ps aux.

I also tried with sudo:

[user@dom0 wyng-backup]$ sudo ./wyng --local=myvg/mypool --dest=qubes://admin-backups/media/veracrypt1/backups/wyng/ --encrypt=xchacha20-poly1305 --verbose arch-init
Wyng 0.4.0alpha2 release 20220903
Traceback (most recent call last):
  File "./wyng", line 3346, in <module>
    aset, dest  = get_configs(options)
  File "./wyng", line 1113, in get_configs
TypeError: arch_init() missing 1 required positional argument: 'opts'

I don’t know if myvg needs to exists, but I tried creating and deleting it. Same with myvg/mypool, which I assume is a directory.

I’m probably missing something. What is it?

@tasket , could you help me here?

@wahvopae Sorry I did not see this thread. It seems my email notifications are turned off.

If you’d like to try again, I recommend using the new Wyng alpha3 branch. There is an issue setup specifically for problems encountered while testing alpha3.