I cannot Backup...SOLVED

Good morning everyone,

I seam to have a SERIOUS problem here as I can not “backup” my qube…
When I am on my user account in my qube for some reason when I try to backup I get all the way to the where I can “click” next after setting my password and location to where I want to backup my qube and I click "next. Well the backup program just “Closes” and nothing happens.

So I next login to my “root” account and I see that up on the top right where we have all our little “applets”, you know the little icons almost all of them load but 1 and it looks like it’s my “qube” icon AND it appears that it is trying to load but keeps “crashing”. I right click on the task bar and just remove all of those little icons. You know right click >Panel prefs>Items (remove all of them).

Next so here I am starting my backup process either I of 2 things happens here…

Either my backup will start and then within a few minutes I get A POPUP…
ERROR “dom0 empty response”, my USB mouse and keyboard stop working and I have to “Hard shut down”


The backup process starts and after awhile, I would say within a hour or so, my qube just “reboots” and all of the sudden I am at my BIOS “power on” password screen. Again I have to force shut down…

Now the only few things I have done over the last few days or so is…

1.) Installed a new USB device and formatted it. But yet my “runtime” environment is stable and I can access this new USB SSD and us it…

2.) I have installed in fedora “Korganizer” which came with a ton of **it in fedora 39, so that I have a calendar. But I installed it from our repos, didn’t connect to internet, and I assume it is safe.

3.) I have installed on my user account that GREAT “Qube tweak” tool from one of our devs and LOVE it and I am using it with no problem. But I think it is causing a problem with my “root” account as it is not installed there and that’s why I have that…qube icon crashing

4.) Built out a Gaming template & domain (Debian 12 xfce) "you know games like THpoker, puzzles,chess games…etc, but again I never went on the internet and pulled everything from our repos. I runs, updates I can play my games, no issues

I would really love to be able to backup as I have just updated/upgrade a ton of tools/build outs and my HVM’s…

Any ideas guys???



What did you configure for the backup destination? If it’s a qube, does the destination qube for the backup has enough disk space?

don’t do that, it’s not needed

My backup destination has always been the same internal 2tb nvme, found in dom0, in fact I have many “backups” in this internal nvme, like 7 in total. I have to attach it to dom0 even though it is seen in dom0. In fact I just attached it now and I have 1013.2Gib of 1.8 Tib free (44% used)
Location seen in dom0 is… /run/media/user name
Owner: username
Access: Read & Write
Group: username
Access: None
Access: None

Well I have never been able to backup on my user account, only under “root”, that’s why I have it. On my user account trying to do a backup is bad. Sometimes the “next” button doesn’t even highlight for me to click next, so I just close it. Then relaunch it and again select destination, set password, then the “next” button will highlight. I click it and BLAMMM, window closes and nothing happens.

This hole other thing like late last night around 2300, my last go before bed.
Logged in to “root”, launched “Backup”, set destination “attached nvme” seen in dom0 (which I have done many times before as I have 7 backups doing it this way for months now), next button highlighted, clicked it and WOW, backup started, OK. Went to do somethings and came back abotu 45 minutes later and WTF, I am on my BIOS “power-on” login screen. This screen comes up when I start my computer, after I input my BIOS power-on password, then Qubes will launch. So while donig my backup either “Qubes” crashed OR rebooted itself…

BIOS Power-on screen only comes up IF the compputer is “rebooted” OR if starting cold.

did you try running command line tool:


to see if you get the same results?

You can run qvm-backup from the dom0 terminal as @scallyob suggested and check if you’ll get any errors in command log in the terminal when backup tool will crash.

Good evening guys…

SO here we are,last night I tried 3x doing a backup, ALL failed. Let me explain.

Under my “user” account, when I launch “Backup Qubes”. I get the popup window, showing everything getting backed up as well as the size, 567.1 Gib. I set my path, I set my password, the “Next” button highlights, I click it and the window just closes. I sat here for 15 minutes hopping that something would happen and it didn’t. NO activity on “dom0”, in fact it sat at 0%,no Hard drive activity, you know flashing light, no other popup window. So backing up under my “user” account is a NO GO, for whatever reason I do not know…

I restart my Qube and do my BIOS ppower-on password and then my "qube: starts, loads, and I login to my “root” account. Again I click “Backup Qubes”, get the popup window, showing everything getting backed up as well as the size, 567.1 Gib. I set my path, I set my password, the “Next” button highlights,I click it and now the “Backup” starts with a progress bar, GREAT. After 1 hour all of the sudden my “Qube” just shut down and now I am at my BIOS power-on password screen. I loging, my qube starts, I login under my “user” account to see if anything at all saved from this backup when I was on my “root” account. Well it did but it was only 17Gib in size. I delete it and again restart my Qube, do my BIOS power-on password, my qube starts, I login under my “root” account and start all over again. Backup started and this time ran for 2 hrs, and BLAM, my Qube shut down and I am at my BIOS password login screen AGAIN. My last backup date is 05/19 & size 148.6 ZIPPED, so obliviously backing up under my “root” account was working til now. I am at
QubesOS version: R4.2.1
Kernel: 6.6.29-1

Now when I backup under my “root” account I am offline
I shut down…sys-whonix,sys-firewall,sys-net & I only leave sys-usb up as I only have USB’s and of course dom0 is up. I have no PS/2 so sys-usb has to stay up.

Again the only reason I have a “root” account is because it’s been the only way for me to backup for a while now…

I keep very detailed notes on a different device of all my backup dates and notes. Upon reviewing them I see that
Well it’s not the “Qube Tweak tool” as after I installed / setup it’s included in the backup before 05/19
Well it’s not my gaming template/domain as I launch and use it to play chess or Mahjong regularly. You would think if anything issue would arise with my Qube it would happen then when I am using it, no nothing doesn’t
Well it’s not the NEW external SSD, I removed it last night when attemping a backup and still reproduced the same results. So it’s not that
Well it’s not the Korganizer (calendar), You would think if anything issue would arise with my Qube it would happen then when I am using it, no nothing doesn’tSo it’s not that

Even went as far last night and “STRESS TEST” my Qube…

I launched 3 HVM’s at the same time, had well over 40GB memory in use between Qubes core processes & 3 HVM’s, VCPU in use I believe was 10 or 11, CPU temps around 170f. In fact 2 HVM’s were updating and the other I was surfing the net. My qube NEVER NEVER missed a beat…

This is pointing to 1 of 3 things that I can think of…
-Kernel panic ( which I don’t really understand yet) / something wrong at the kernel level
-Qube Backup tool failure (I know I can’t backup on my user account)
-NVME failure…

Thanks guys I will try the …qvm-backup tomorrow I am BURNT Out right now trying to figure this out

Ok guys,
It finally my qube did the “full” backup in terminal with no errors and returned 100%
with the cmd that @scallyob gave me. Thank you very much. So my qube stayed on the hole night which I don’t want. My thinking is can I execute

qvm-backup PROFILE && halt - halt

and after my qube backs up it will shut down if there are no errors?

Also I have locked out my “root” account now since I can now back up on my user account…

You can read the manpages with:

man qvm-backup

But I do not see that option with the command line tool.

Glad you got your backups working! I know what that’s like.

Yes I was reading them and don’t see the option to shut down after backing up. I will try and see if it works on the next go for backing up, I don’t think it will hurt.

qvm-backup PROFILE && halt - halt (will backup qube and shut down after done with a return of no errors)

qvm-backup PROFILE; halt - halt (will just shut down qube after backup)

qvm-backup PROFILE || halt - halt (will shut down qube after backup with errors)


qvm-backup PROFILE; -shutdown (but i think a time would have to be set here, like 7hrs = 420 minutes

qvm-backup PROFILE; -shutdown & 420 minutes

Things I have been thinking about today after a SUCCESSFUL back up using terminal

Believe me the last few weeks I have been banging my head, sucks not being able to back up

The GUI program runs systemctl poweroff once the backup is done if you checked the box to shutdown after backup, see the code qubes-manager/qubesmanager/backup.py at f701e834846736bbe81e3333b6af2345553ee301 · QubesOS/qubes-manager · GitHub

It’s not a parameter from qvm-backup, so you can add && systemctl poweroff. The command halt is a symlink to systemctl so I suppose it does the same thing as systemctl poweroff.

As you had issues with the backup tool, I’d advise you to verify at least once backup with the backup restore tool, there is a test mode that will check the backup is working without doing anything on your machine.

1 Like

Yes I am doing that now… verify backup with the backup restore tool. I am verifing the backup I just did with qvm-backup “hope all goes well”. As to why I am having a problem with the “backup tool”, IDK… The only two things I have installed in dom0 are
KDE partition manager
and everything else is original from Qubes iso and whatever updates & upgrades from Qubes

So what you are saying i can run in terminal…

qvm-backup PROFILE && systemctl poweroff

And after backup my qube will power off??


You can try running qubes-backup from dom0 terminal and check if it’ll give you any errors on crash.

Well I attached my nvme to dom0 and ran my verify backup on the backup I did with qvm-backup PROFILE, and it
verified successful!!

OK, I will use… qvm-backup PROFILE && systemctl poweroff

I have successfully did a backup in dom0 terminal and @solene wanted my to verify it. So it appears I can only backup my qube this way for now. As to why I can’t use the “qube backup tool” IDK. It started happening about 2 months ago around late March early April, and thats why I made a “root” account which I have now “locked”. BUt even then of late now I couldn’t even backup oon the “root” account. But it now seams to work on my user account with qvm-backup…