Hvms get no Wifi/Internet

My HVMs arent able to connect to the internet after making them a HVM
ive tried manually changing the ipv4 settings to be the same as the net cube settings but still no success
any idea what could cause this and how to fix??

It’s a little hard to follow the gibberish.
If I understand you, you have WiFi through sys-net and a Windows qube
attached to it - either directly or via sys-firewall.

Open qube settings for the windows qubes and note the IP address.

Go in to the windows qube network settings in Windows.
Turn off dhcp.
Configure IP address with the IP address from above.
Set netmask to
Set DNS to
Save settings.

ive done that just right now but maybe im misunderstanding something ive done exactly what u described but also set the default gateway inside windows to the same as what it says in the qube manager inside the windows settings net cube somehow wifi still doesnt work maybe its on my end and i dont know how to navigate windows ive tried changing the ipv4 settings inside the windows settings menu and also inside the pretty outdating looking old windows “control panel” i wish i could show you a screenshot but im on mobile and im using a burner email and forgot the password so idk how to send u a screenshot ill just type it out lol

Network Connection Details:

IPv4 Address
IPv4 Subnet Mask
IPv4 Default Gateway (Idk if i should show that im too lazy to check if thats my ip but it should be the correct Value)
IPv4 DNS Servers

and there are also some ipv6 fields but they are empty maybe i need to also add my net cube settings in there?

some useful infos could be that im using my igpu to display qubesos and blacklisted my nvidia gpu maybe that has something to do with it? seems pretty unlikely but idk

also my windows vm uses HVM instead of PVM and also something important to note is that my windows hvm cant output any audio it just says it has no audio output devices for some reason literally just followed this elliot qwt windows guide to set up the vm and im not usong the windows installation tools because some random txt doc told me not to or whatever

sorry if i come over weird as fuck its like 4 am where im at rn and im kinda drunk and i just want to browse the web using my windows vm

This should be the value shown in the Qube Settings window. Nothing to
do with “your IP”