HP Pavilion M6-1076LA notebook compatibility

Dear all,

I am enthusiastic about trying this OS ver 4.1.2. I couldn’t find my notebook in the HCL so I gave it a try after enabling virtualization in the BIOS. I haven’t find any other of the mentioned items in the guidelines to be configured in the BIOS. This notebook is a HP Pavilion M6-1076LA, AMD A10-4600M APU with Radeon HD graphics, born on year 2012, BIOS vendor Insyde and BIOS version F.36. It originally comes with a HDD with Windows 7, but it was replaced with a 240GB SSD with Windows 10. As I didn’t want to delete WIN10 yet, I initiated the installation from a USB stick and I was stopped at a black screen after some lines. I modified the option to do a verbose installation, including this: “options=console=vga efi=attr=uc” (without the inverted commas) and the installation finished correctly (only to mention that the message saying “unsupported hardware detected” showed up and I shrinked one of the big partitions of Win10). After the suggested reboot to start using Qubes, Win10 starts inmediately without any menu. I tried the repair option in the USB stick installation but it said it couldn’t find the installation on the SSD. Starting the installation again shows this 2 partitions, that if I remember well, were not there before: SDA6 as ext4 and SDA7 as Encrypted (LUKS).

Questions: Any ideas if this hardware will work with Qubes? Any solution you can propose for my actual Qubes installation?

I am willing to install it again in a new and totally empty SSD if necessary but only if nobody proves me that it won’t work because of the hardware

Many thanks


Do you see Qubes OS boot entry in your BIOS?
Did you install Qubes OS in UEFI or in Legacy BIOS mode?
If you’ve installed in UEFI mode and you don’t see Qubes OS boot entry in your BIOS then try to add the boot entry manually.
Boot from Qubes OS installer USB stick with repair option and run this command:
efibootmgr -v -c -u -L QubesOS -l /EFI/qubes/grubx64.efi -d /dev/sdb -p 1
Change /dev/sdb to your SSD drive name and -p 1 to the correct partition number of the EFI System partition on your SSD.
You can find out the correct SSD drive name and EFI System partition number with this command:
fdisk -l

I replied to this from my email 2 days ago but as I don’t see that message I am now replying from the web.

Thanks for your reply. I uploaded this images as I think that will be easier to understand than for me to try to explain it. I think I installed Qubes in UEFI mode. I run that command but I am not sure if I have to choose sda6 or sda7 as both are Linux filesystems of Qubes as you can see in one of the images.

I tried sda6: Afterwards, booting from the USB stick does not show the boot entry and booting with the USB stick not attached to the PC makes Win10 to load inmediately.

So then I tried sda7: The results are exactly the same.

BIOS photo: 20230623 131908 — Postimages

fdisk & efibootmgr photos:Unsaved — Postimages

Please someone help me with this issue. Thanks!

Sorry that the replies here are not very fast. This is a small community of busy people…

Looks similar to these issues: Boot device not recognized after installing, how to fix this through rescue mode, "No Bootable Device" after Qubes OS installation, "No bootable device found" After completing qubes os install. There are a few possible solutions in there.

This might be the reason: [qubes-users] New mailing list posting policy.

I don’t see anything in the spam filters. We usually check at least once a day (often more).

Here you can see a screenshoot of my reply by email

Oh, it looks like you’re replying on the forum, not one of the mailing lists. It’s a different system.

Could you please elaborate your reply? I don’t remember subscribing to a Qubes’ mailing list.

This page already documents all the details:

Exactly. You probably never subscribed to any of the Qubes mailing lists and probably never used any of them. You’re replying on the forum right now, and your screenshot shows that you’re emailing a reply to this very same forum. No mailing list involved, so the mailing list policy @fsflover linked above doesn’t apply.

1 Like

Hi, I looked into the posts suggested but I am still unable to make this PC boot the Qubes installation, it goes into booting windows 10. This PC has only one internal SSD drive. Basically what I tried to solve the problem was: changed the bios to legacy, then:

I insert a USB stick with Qubes image, power on the PC, choose “Rescue a Qubes OS System”, after all the things that loaded I have a green line on the bottom that reads [anaconda], I press alt+tab and then I type:

efibootmgr -v -c -u -L Qubes OS -l /EFI/qubes/grubx64.efi -d /dev/sda2 -p 2

Does that command get saved into the SSD or into the USB stick drive?

I suppose that adds an entry to a sort of grub style menu, I guess the problem is that menu is not loading

At the BIOS I don’t have an option for booting Windows or Qubes.

Running “fdisk -l | less” shows the following (among others):

Disklabel type: gpt
device: /dev/sda2, size: 99M, type: EFI System
device: /dev/sda6, size: 1G, type: Linux filesystem
device: /dev/sda7, size: 94.5G, type: Linux filesystem

(I don’t have a sdc)

I am not sure if the last bit of efibootmgr is the one I need to try (sda2 -p 2).
After that should I remove the USB stick before rebooting? I suppose that yes, but I am not getting different results for now.

ls /sys/firmware/efi


config_table efibars fw_platform_size, systab

Please I need “for dummies” step by step instructions so I don’t miss anything. If you ask me for some information please tell me how to obtain it.

Many Thanks


I add more info: At the setup utility, system configuration, I disabled legacy support and now after turning on the PC if I press F9 y get into the boot manager where I can see “Qubes OS (ADATA SU630)”, so I selected it and then I get a Qubes menu: “Select operating system” with two options: “Qubes, with Xen hypervisor” and “Advanced options for Qubes (with Xen hypervisor)”. I go for the first one and I get:
“Loading Xen 4.14.5 …
Loading Linux 5.15.94-1.qubes.fc32.x86_64 …
Loading initial ramdisk …”
I get a black screen, I waited for about 10 minutes but nothing happens

You need to enable IOMMU-virtualization in your BIOS.
It shouldn’t prevent Qubes OS to boot if not enabled, but you will miss some Qubes security features.

It will be saved into the EFI partition.
The command should be as follow:

efibootmgr -v -c -u -L QubesOS -l /EFI/qubes/grubx64.efi -d /dev/sda -p 2

it’s not -d /dev/sda2, just -d /dev/sda.
I you want a space in the name use quote (e.g. -L 'Qubes OS').

and as mentioned by disp6252:

in this example, your EFI partition is -p 2 and the disk is -d /dev/sda.

You could try:

You could also try:
There is a lot of forum post, you have to search and try, as only you have access to your hardware. :slight_smile:

You could remove quiet from the kernel option to have a better logging of what happen.

You could try to install with the latest-kernel option from the installation USB.
You could give a try to Qubes 4.2-rc3. It’s stable enought to be used as a daily-driver.

Thanks for the suggestions. I removed quiet and tried a lot of other things I’ve found on the forum posts but none is working for me. I downloaded Qubes 4.2-rc3 but I get a black screen after choosing almost any option at the grub menu (verbose is the only one that shows some lines but then it goes into black screen), so no installation of this new version was possible. The weird thing comes now as I used the same usb stick all the time and what happened is that I erased the stick and transferred again Qubes-R4.1.2-x86_64 to the drive, then I tried all the options of the grub menu and I get the same results as with Qubes 4.2-rc3 ! I connected it to different USB ports and it’s the same!. This Qubes 4.1.2 was not giving me those results before! I suppose the USB stick is not reliable, even when the WoeUSB-ng software said it was successful with the operation of burning the image to it. I am going to see if I can find some DVL-DL blank disks locally and try using them.

From an idea of to this post:

you can add: loglvl=all guest_loglvl=all to the end of the GRUB_CMDLINE_LINUX.

I guess you have created your usb installation with dd ?

This user resolve his problem by using Fedora Media Writer.

I know your problem is not with the installation, but it worth trying several method.

Don’t limit yourself to this forum.
You could try searching on a search engine with some keywords like that:
fedora HP Pavilion M6-1076LA black screen
fedora HP Pavilion black screen
fedora block on Loading initial ramdisk

Hardware problem is always hard and boring to debug sometimes. :slight_smile:

Thanks for your reply. I bought 2 DVD-DL and burned both versions of Qubes. I am having the same results! Why on earth is that now I cannot even get to a command line when booting from the DVD or USB in UEFI mode, considering that I was able to do it a few days ago? How I can see the contents of those logs generated by loglvl and where are stored? I removed quiet and added nomodeset --verbose to the grub lines and nothing changed. A few days ago I was also able to install qubes (even when it did not work when trying to boot from that installation), but now I can’t reach there! I have not modified anything on the firmware of the PC (BIOS setup options), and it doesn’t have much to change there anyway.
I tried installing in legacy mode and I was able to go further, this is the error I get: “X startup failed, aborting installation. The installation cannot continue and the system will be rebooted. Press ENTER to continue”. I think the problem is with my GPU or something else regarding the video, I am going to try modprobe.blacklist=amdgpu

I’ve tried modprobe.blacklist=amdgpu and nomodeset all together but nothing changed.

Now booting from the usb in legacy mode goes into Grub bash and shows “No filesystem detected- Sector size 512B…” when I type ls (hd0,msdos1) or ls (hd1), for ls (hd0,msdos1) it shows “Partition hd0,msdos1: Filesystem type fat, UUID A428-E962 - Partition start at 4096KiB…”

Booting in UEFI from the USB goes into grub and then black screen after I choose some option. “Troubleshooting…” is the only option that shows some lines before the black screen.

I am just trying to see those logs generated previously by loglvl=all guest_loglvl=all

This error remember me some troubleshooting with 4kn drive (aka drive with 4k native sector).
related topic: https://forum.qubes-os.org/t/ext4-vs-btrfs-performance-on-qubes-os-installs/13585

From what I’ve read here, 4kn drive are not yet supported by lvm or only Qubes, I don’t really know.
Is your SSD is a 4kn drive (as opposed to 512e) ?

Could be the reason why Qubes OS doesn’t start ? (It’s a guess, I could be totally wrong here)

The TLDR is to install Qubes OS with Btrfs as filesystem.
You need to do manual partitioning and explicity choose Btrfs in the installation option.

1 Like

I succesfully installed Qubes R4.2.0-rc3-x86_64 thanks to your help. Many thanks for that!

The only weird thing until now is that if I press ‘e’ in the grub menu and then I remove ‘quiet’ and press F10 (for booting) it shows a lot of lines but it never loads the graphics, I mean it never ends the booting process, however the PC is not unresponsive as if being there I press crtl+alt+del it shows some lines and reboots.