How use debian bookworm in qubes 4.1?

I want use debian bookworm in qubes 4.1
When I changed /etc/apt/sources.list and after that I print apt update. All been OK.
And when I use apt upgrade all OK too. But when I use apt full-upgrade GUI broken.
apt full-upgrade will remove some qubes packages as qubes-gui-agent.
In Whonix workstation I have this problem too.
Can I use debian bookworm in qubes 4.1?

Run the following before full-upgrade:

apt-mark hold qubes-core-agent
apt-mark hold qubes-core-agent-networking
apt-mark hold qubes-gui-agent

Alternatively I also found this solution: Kali does not upgrade - held broken packages? - #17 by trizzo

You could also try installing dummy-dependency (Debian Packages - Kicksecure)

It’s a common problem, multiple answers have been posted around the forum, just search a bit if these don’t work.

You can try the template unman has made

1 Like

You can also upgrade bullseye to bookworm in place, following
standard process.
Clone the bullseye template.
In the new template, apt update.
Change the repo definitions in /etc/apt/sources.list and
apt upgrade
apt full-upgrade

bookworm is a testing release. Things will break - it’s expected.
When we get to freeze it may be worth raising issues, but not now.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

Yes, I did it. But when sudo apt full-upgrade GUI been broken.

When I do it after sudo apt full-upgrade I have:

The following packages have unmet dependencies:
 libgirepository-1.0-1 : Breaks: python3-gi (< 3.42.0-1+b1) but 3.38.0-2 is to be installed
 qubes-gui-agent : Depends: xserver-xorg-video-dummyqbs (= 4.1.26-1+deb11u1) but it is not going to be installed
                   Recommends: qt4-qtconfig but it is not installable
                   Recommends: pulseaudio-qubes but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

OK. I will try it now.

You can search my posts about using bookworm. I tried it and after many breaks, I stopped using it. Unman is right.

You don’t need to put that hold on.
The upgrade will work fine if you update the Qubes repositories also.

Bookworm is quite stable and usable.
salting doesn’t work because of missing packages - We’ll need to fix this
before release.


So… bookworm is usable and stable to test in order to break, and that’s expected :smiley:

There is a difference between “quite stable” and “stable”, which you
have not honoured.

1 Like

I’ve had such success with bookworm that I’ve transitioned most of my builds to it and rarely dust off bullseye.

I used the following to create a debian-12-minimal template after cloning debian-11-minimal as source:

apt update
apt upgrade
sed -i 's/bullseye/bookworm/g' /etc/apt/sources.list
sed -i 's/bullseye/bookworm/g' /etc/apt/sources.list.d/qubes-r4.list 
apt update
apt upgrade

Above no longer works as expected but, this does.