How to use Qubes clipboard feature from AppVM running minimal template fedora or debian

Hello,

Thanks a lot for your work on this amazing project !! Big high 5 to the team and all contributors :slight_smile:

I am using minimal templates where I add just what I needed and it is just a wonder.

But I get stuck with one thing, on very minimal templates I don’t know what package to install in order to get the copy / paste feature of inter-qubes clipboard to work from my minimal template based AppVM :\

I get it to work with more gui-oriented appVM with nautilus and qubes-core-nautilus but in VM that has strictly only xterm for example how to I get it to work without gui ?

If anyone can help on that specific topic as I guess some might/must have been in a similar situation
.

Thanks !
Guillaume

None needed.

That’s because of xterm, not Qubes. You’re not missing any packages or anything Qubes-related. It is simply that xterm doesn’t follow the clipboard behavior you’re expecting, so you are not actually copying text into the qube’s internal clipboard. Therefore, there is no text to copy from that qube’s internal clipboard onto the inter-qube clipboard.

See here for more info:

And these search results:

https://duckduckgo.com/?q=xterm+clipboard

thanks @adw it seems you did have this issue before :blush:

so to confirm the solution is to add

XTerm*selectToClipboard:true

into default xterm configuration file ~/.Xdefaults

answer has been given previously here indeed

I did try to search here before but didn’t match the rights keywords to find the solution.
Hopefully this topic will index more keywords to bring here future users stuck the same scenario…

Thanks @adw :pray: for your thoroughly help !!

2 Likes

actually in order to work with a minimal template + AppVM context I needed to apply that parameter as default configuration at a higher level.

Add this line

*selectToClipboard: true

to the file /etc/X11/app-defaults/XTerm in your template
instead of user level at ~/.Xdefaults in AppVM (that works for test but didn’t stay after reboots)

3 Likes

the solution above is for debian

for fedora you need to modify the file /usr/share/X11/app-defaults/XTerm

adding the same parameter *selectToClipboard: true at the end of file

in your templateVM

What makes you say this?
It could only be true for root, not for user: for user, ~/.Xdefaults
works, and provides granularity across qubes, which the template change
doesn’t.

I have tried and it did work…

Maybe I shall try again more carefully then :upside_down_face: