How to USB power/control | AUTOSUSPEND disable on qubes sys usb

Hi everyone.

I’m am in a situation where I need to probably disable usb:

  • AUTOSUSPEND and/or
  • power/Control
    Either from the dom0 and/or sys-usb (USB vm).

I have a windows android software that requires to be initialized via android “BROM_MODE” or “Mediatek Preloader” when the phone is off using volume combinations while inserting the USB cable for the software to initialize. I have used the same software on a windows10 installed laptop without QubesOS and with worked seamlessly.

At the moment I am trying to use the same software in Windows10-StandAlone-VM on Qubes but I am having issues with usb being automatically disconnected from BROM_MODE, then powering the android phone after the device is being detected by the Android software installed in Windows10-StandAlone-VM but this is not supposed to happen. I have disabled the power control option in the Windows10-StandAlone-VM on Qubes but didn’t solve the problem.

After some troubleshooting, I discovered that this is probably caused by the USB AUTOSUSPEND, AUTOSUSPEND_TIMEOUT_MS, power/control and/or power/level configuration in the /sys/bus/usb/Devices/ directory either in the sys-usb or dom0 vm.

I have I changed my disposable USB to a stand-alone us so as to contain the configurations.

I have tried couple approach that I discovered online such as:

  • Updating the /etc/default/grub file with coreusb.autosuspend=-1
  • Creating USB Udev rules to disable power/control by set to auto
  • Using: powertop, tlp and hub-ctrl
    None seem to be working at the moment.

I also noticed that in the /sys/bus/usb/Devices/ the external input device configurations are disposable after removal and they are symnlinked so, I can’t update the power/ configurations for inputted usb device individually because it will be discarded and replaced to default configurations after I remove and input the USB again.

I don’t know maybe it’s the sys-usb or dom0 that is responsible for the AUTOSUSPEND and power/ configurations.

I appreciate all your supports to resolve this issue.


Might be related: