How to test intel integrated graphics?

I have Intel Alder Lake i7-1260P 12th Gen and I don’t know if the integrated graphics are working or not.
If I played some youtube video inside one of the AppQubes the CPU of the Qube goes up to 90% and the video is not running smoothly, so I think the integrated graphics are not working

However when I ran this command in dom0: glxinfo|egrep ;"OpenGL vendor|OpenGL renderer" I get this result:

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)

and when I run this command in dom0: lspci -k | grep -EA3 'VGA|3D|Display' I get this result:

0000:00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
DeviceName: Onboard - Video
Subsystem: ASUSTeK Computer Inc. Device 1e02
Kernel driver in use: i915

How to test intel integrated graphics?


Not a guide, moved to support

I had the same issue which is now fixed after upgrading to Qubesos 4.2 (and coreboot bios upgrade, 8.99 if you have a starbook)