How to set up Split-GPG

Hey there,

I would be very grateful if anyone could have a look a my problem:)

I was trying to set up Split-GPG. I did as described in the how-to: (Split GPG | Qubes OS) however, I exported the key on my old system using gpg --output ~/mykey.key --armor --export then transferred it to the fedora-34-vm that it set up to be my gpg-vault. Here i tried to gpg --import the key but got an error that i think was saying gpg: no valid OpenPGP data found. so i copied the key to /home/.gnupg and started the terminal again and tried gpg --import but nothing won’t happen at all, meaning the cursor is hanging out blinking – sorry for my non-specific language.

Again if anyone could help me I would be extremely grateful!!

I forgot to mention, the moment I execute gpg --import, a file is created with the name:*name*-gpg-vault.1612 in /.gnupg

Seems like there was an error when you exported your key. Besides, you need to export the secret key, not the public key.

oh, okay, thanks! So i’ll try again with --export-secret-key

Mhm, i tried it again and got the exact same result. I did run the gpg --export-secret-keys >allkeys.asc transferred the file to my gpg-vault-vm to /home/.gnupg and tried gpg --import allkeys.asc as a result I’ll still get:

gpg: can't open 'allkeys.asc': No such file or directory
gpg: Total number processed: 0

Anyone an idea what might be wrong?
Thanks so far!

Wrong filepath.

gpg --import /home/.gnupg/allkeys.asc

thanks!! :ok_hand:

If the problem is resolved, please select the answer and accept it as solution.

sure, i am just checking if split gpg is working now

1 Like

Okay, i did as said in the split gpg howto, i formated my public key to be 16 characters long and exported it. I configured thunderbird to use my an external key and imported it via the key-manager. But thunderbird does say:

the secret key that is required to decrypt this massage is not available.<

when i try and send an encrypted email to myself thunderbird answers:

Sending of the massage failed.

any ideas?

Check again, the guide works.