How to set up a WI-FI connection?

Trying to connect sys-net to built-in WIFI device on laptop.

In the NetworkManager window, I created a new WIFI connection, entered the password for the connection. Now how to use it and connect to sys-net?

I go into the settings of the sys-net cube and the “Devices” tab is not clickable, why not clickable, how can I make it possible to assign devices?

Device “Realtek 8168/8111”. As I understand it, the system detects it and the driver does not need to be installed separately. Help, for several days I have not been able to connect the network.

Did you have sys-usb?

If not:

I have a built-in wifi module in my laptop, not USB. In theory, from what I read on that link, it’s easier to transfer the device to sys-net (I don’t have sys-usb), but the Devices tab is not active.

Do you mean sys-usb is not started? I’m just asking because I had this issue.
After running “sudo qubes ctl state.sls qvm.sys-usb” and “qvm-start sys-usb” in the dom0 terminal sys-usb was working again.

1 Like

I don’t have a sys-usb cube at all, as such, only sys-net. Maybe during the installation of the system did not check the required box. Is this sys-usb required? If so, is it possible to create it manually without reinstalling?

@olimpset, when the sys-net is running (typically autorun at boot, you can stop it & then try to access - which will require bringing down dependent Qubes like sys-firewall beforehand in reverse order of their startup) you cannot do much in the Devices tab - it will be greyed out. Are you unable to even bring up the greyed out visual within the sys-net Qubes Settings dialog (I’m thinking that that is not the case)? The device you mention may be PCI but internally it could just as easily be USB - googling Realtek 8168/8111 or pulling system information from a command line (CLI) to post may help us all help you. If you stop the sys-net & then can examine the Devices tab with fuller control, you can look for the exact device (which if it’s USB it wouldn’t show up there) and try to add it to your sys-net & start that back up (don’t forget to wait for sys-net to successfully complete it’s startup & then start sys-firewall).

My Devices tab in sys-net is not available, I can’t even log in. I’ll try again tomorrow.

Log in where? Into Qubes? If not into Qubes, then I’m confused with relating log in with Devices tab.

it’s not clear because of Google translator) I’ll try again) There is a Devices tab in sys-net. But I can’t access this tab because it’s inactive and I can’t click on it

@olimpset are you past the decryption phase (what others may refer to as the LUKS password part of getting in)? You stated the following:

Which I’m going to say probably looks to many of us like you are past the desktop login most know of for Qubes (regardless of desktop manager - Xfce, KDE, or whatever, you - in my hypothetical case - have gone past LUKS, to a login prompt - which you had to answer correctly before being taken to a form of desktop which likely had sys-net running or there would simply be no Network Manager to interact with). Sorry, but we need to get a better mental image (not requesting actual photographic evidence but please elaborate in text if you are able) of just what you are dealing with.

I also wonder if Qubes is the only operating system in play here (maybe we should ask specifics about the choices you made at install, post-install - like, for your computer is it dual-boot? or simply Qubes 100%? or did you modify it much at some point going for a special feel other than straight from basic vanilla install?)? Try to take it slow & build up to an explanation. People here are quite patient when you approach it with reasonable care (language issues aside).

After many attempts and days, I finally solved the problem.

What I haven’t tried:

  1. I restored the disk image many times (so as not to reinstall the system). Surely, the flash drive received good wear.

  2. Tried to install rtw89 driver.
    Then, after installing the module, the template refused to run at all, since the module was not signed and it could not be loaded. Spent some more time.

Then I met one strange comment on another forum, the essence of which is to set the kernel value to none in the sys-net cube.
And what a surprise I was when WIFI networks appeared after this action. And without installing a driver.

Because info given by the OP here is pretty modest and unclear, I would strongly recommend other users reading and thinking to implement this, first to read

This means that you are using the native kernel,not one provided by
dom0.In the docs