How to restore data from Qubes 4.0 backups in Qubes 4.2

I thought it’d be a matter of doing a few simple mount commands but apparently not. I have zero clue how to access the data I backed up. Fedora 36 standalonevms apparently can’t launch at all in Qubes 4.2.

I have the data in two backup formats: Qubes Backup files and an image of my entire Qubes 4.0 install before update. I should be able to retrieve the data from either, but I don’t know how at this point besides wiping my current install and restoring the backup image to disk which is an absolute last resort. I feel like this should be more readily available information but it’s not.

Somebody PLEASE help me get my friggin data back


so you restored your Fedora 36 already on 4.2 but can’t start it? Why? What is the error message or problem?

If you just wanna try to extract the data from the Qubes backup file the instructions are here: Emergency backup recovery (v4) | Qubes OS

So it’s supposed to work…? WTF. It says this:
qrexec-daemon startup failed: 2024-03-09 20:56:10.417 qrexec-daemon[13060]: qrexec-daemon.c:144:sigchld_parent_handler: Connection to the VM failed

Doesn’t even point me to a log file to check out as most qube startup failures do.

“v4” huh… I remember trying to follow the v2 version of those instructions last night and failing. It said “Qubes 2.0 and up” so I figured it still applied to modern Qubes. Stupid search engines sending me to old pages ffs. Thanks, I’ll give this a shot now

As a data point, I can confirm being able to successfully restore 4.0 backups in 4.1 as recently as October 2023. I haven’t tested it again since then, and I haven’t tested restoring in 4.2 yet. All versions of Qubes are supposed to be able to restore backups created in older versions. If it doesn’t work, that’s a bug.

This sounds very generic to me. Have you tried to restore it again from backup or looked for another solution, maybe here or here? Because I used older Fedora versions on 4.2 too and had no problems at all.

Sure, like everything in IT works out of the box :wink: I never tried it… yet.

I ended up finding a hard drive large enough to hold my old Qubes image and just went that route. I got my files back… not that I’m happy because now I’m having another problem. ISTG R4.2 suxx

Thanks y’all

The problem description seems that it is not information integrity issue but rather a R4.0 template not booting well under R4.2 issue.

Use a R4.2 template after restoring from backup should be OK.

I observe similar issue when upgrading a R4.0 into R4.2 and suspect that it is the qrexec protocol change from R4.0 to R4.2. If you have trouble with the standalone VMs, you can try mounting the private storage and the root storage on another vm in some ways and copying out necessary data.