How to reset screen resolution on Qubes OS 4.1.1 by editing kernel boot parameters?

System: Acer Nitro 5
The QOS411 recommended auto screen resolution for my laptop: 1920x1080 @144Hz
Since the font size was very small even after setting dpi from general settings, I tried resetting screen resolution through settings>Display>Res: to 1600:900 from the existing QOS411 recommended 1920x1080…a ratio-wise equivalent resolution that worked for me on Windows. This resulted in a black screen for a few seconds followed by resolution resetting to 1920x1080 without any message, reason, or option. I repeated this several times with the same outcome.
Finally, just to force the resolution, I HIT ENTER just after the black screen appeared after I reset the resolution to 1600x900, assuming that there is a message behind the black screen asking to keep the changes. This time QOS411 didn’t reset it back to 1920x1080 but got stuck at the black screen.
Not to mess up the installation, I drained out the power of the laptop instead of hard resetting with the power button. Restarting QOS411 works till login, and then gets stuck at the black screen after logging in.

I have tried grub commands at boot after entering c at boot menu to add screen resolution parameters through gfxpayload:
grub> set pager=1
grub> vbeinfo

but vbeinfo returns “command not found” or something similar.

QUESTION: How do I reset the screen resolution by editing kernel boot parameters?

Follow-up discussion moved to thread:

I spent about an hour on the black screen for what the experience appeared. However after pressing several buttons, CRTL ALT F1 at the same time the screen came back. CRTL ALT ESC does bring the command line. Hope this helps. I did not wanted to leave you hanging.

CTRL+ALT+F1 to F6 bring up the tty modes.
For me the CTRL + ALT + Esc brings up a huge list of all commands possible (about 3000).
I am trying to reinstall xfce since I am able to login after installing plasma-kde, but xfce is refusing to budge. I even renamed the ~/.config/xfce4 folder, but no use.

Reboot worked. Answer on the moved post “black-screen-after-login-need-to-reset-screen-resolution

Thanks again for helping out.

No problem, if could be an issue with GPU not sure. While tracing back on the logs I found that it may have been the GPU was momentarily disabled. You’ll solve it.