How to recreate default-mgmt-dvm?

How do you recreate or reinstall the default-mgmt-dvm template?

I deleted it after messing it up trying to troubleshoot it, unaware of the recently reported bugs that were probably causing the problems. I’ve already tried reinstalling the packages mentioned in QSB 45 but it didn’t change anything.

sudo qubesctl state.apply qvm.default-mgmt-dvm

That put default-mgmt-dvm back, but seems to have caused a ton of other problems.

When I ran it, I got a this window:

I rebooted and the tray is missing the app the shows the running VMs, the one that shows the free space, and the Qubes Updater. Now on top of not being to able to update, I can’t even see what is running. :frowning:

Sorry, I cant see what that window says. Can you tell me?

In any case, that salt command cant have done anything to affect the
applications you mention, (at least not that I can see).
Look at the code -
All that is doing is creating the DVMTemplate, with a black label, no
netvm, and then setting it as management_dispvm using qubes-prefs.
Hard to see how that is going to affect the gui widgets. I would be
looking elsewhere.

I see the code, but I can’t copy paste it because that widget is gone too. That error came up the second I ran the qubesctl command you posted. I don’t know what the connection is, but the timing is way too convenient for it to be unrelated. As far as writing out what it says, I’m not doing that. It’s right there in the screenshot, I don’t know what else to tell you. That command it says to run doesn’t exist either.

“I’m not doing that.” - Then I cant help you.

Did you try running the suggested command?

This is most likely a bug in the widget. To restart the widget, run ‘qui-domains’ in dom0

I did, but I couldn’t find it. After some more digging and testing, I noticed qubes-desktop-linux-manager didn’t get reinstalled. Installing it and restarting again fixed that issue. The Fedora 32 template still won’t update, or dom0 thinks it has updates when it really doesn’t. I’ll probably switch to f31 or debian templates until f33 templates are available. Thanks for your help.

1 Like