How to make display resolution stick?

(Copypasting this from the mailing list since nobody replied there)

I have more computers than keyboards so I use a KVM. I have this Debian computer that always switches back to 1024x768 whenever the KVM returns control to it. It’s not a game breaking bug but it does get more annoying as more of my systems become “infected”. :sob:

Ever since I updated my Qubes computer to 4.2, it has been doing the same thing. I keep finding myself wondering why everything looks so big then I remember I have to change the resolution back lol. With Qubes specifically, this only happens when resuming from screen lock. If I come back to Qubes before the screen locks, then the resolution remains fine.

This didn’t happen in 4.0, and I’m guessing it could be related to xfce since both systems are running that now. Anyone here know a fix (without changing xfce)?

Maybe set the proper resolution for the display and then save the display profile?
https://docs.xfce.org/xfce/xfce4-settings/display