How to install AppImage?

I can not for the life of me install an appimage called Ledger Live. Ive fallowed all the tutorials from Qubes, Ledger Live and youtube but just cant get it to work. Please help.

Appimages usually are stored in userspace if i am not mistaken, so you should install them in your AppVM, not the template.

For disposables, they must be installed in the disposable-template.

So usually those are binary files.
Download your Appimage and store it somewhere with persistence. Usually ~/Applications/Example.AppImage.

those files must be executable to be executed of course. This can be ensured with:
chmod +x ~/Applications/Example.AppImage

To run them, you just do ~/Applications/Example.AppImage.

If this is too much typing for you, there are a few popular options for that.

The ugly and tedious:
You can set an alias with echo "alias Example='~/Applications/Example.AppImage'" >> ~/.bashrc.
This is good if you only have one AppImage and maybe don’t want to create an extra folder for it or something.

When having multiple AppImages having many aliases gets out of hand quickly. So the better approach is to

add your Applications folder to the $PATH
You can do so with echo 'PATH=$PATH:$HOME/Applications' >> ~/.bashrc
After this command you need to open another terminal or resource with source ~/.bashrc

If you store them in ~/Applications/ the start menu should be able to pick them up, if the developer have enabled .desktop support. [Edit: Not if you do not run them with AppImageLauncher]


Thank you for the detailed reply but when I try to make the file executable it give me an error. chmod cannot access

The leading / in your commands path means “search for the Download folder in the root of the file system (/)”. It is an absolute path. It can’t find the file, because there is no Downloads folder there.

Without it, it is interpreted as “search for the Downloads folder in the directory i am currently”, that is relative to your location, so those paths are called relative paths. You are in your home directory so the Downloads folder is right there.

Remove it and it should work.

Here is more about absolute and relative paths if you are interested (although that’s pretty much everything one needs to know about relative vs absolute paths).

1 Like

Did I do it wrong again? It still wont work. Im comming from Windows so I dont know anything about Linux. Useing the Fedora template but also tried on Debian and neither worked.

You addressed the folder correctly, but then you inserted a space after “Download”
spaces are interpreted as a delimiter so the command thinks “i have do make the file Download and the file ledger-… executable”.

You have to add a / directly behind the folder.

The command you need to run would be chmod +x Downloads/*.AppImage. This will make every file that ends on .AppImage in your Download folder executable.

Just in case you ever have to type a path with a space in the name in the command line: Escape it with \. This tells the shell (the thing that interprets what you write into the terminal) “the space the follows this \ is not a real space, but part of a name”. So if you want to make all AppImages in the folder “My Applications” executable it would be chmod +x My\ Applications/*.AppImage


Thank you very much! Ive been stressed about getting my data off Windows asap. Im looking foward to learning more about Linux and Qubes. Thinking about Manjaro as a main OS instead of Windows.

1 Like

Great choice to walk away from windows and trying out manjaro! Welcome to Freedom :slight_smile:

1 Like