How to increase dom0 RAM size?

My qubes os have a maximum ram size of 4080 MB. I want to increase it to around 8GB.

I found this somewhere:

nano /etc/default/grub2 
# change maximum memory limit to desired size and run
grub-mkconfig -o /boot/grub2/grub.cfg

It didn’t work and just reset the theme.

Now I am finding a convenient way to change dom0 max ram size. Please help. I am new.

I have two 8 GB ddr4 rams.
Please let me know if any further info needed, except why I want to increase RAM size.

I think something like this here is needed:

The 4 GB is the memory available for dom0, it’s not the total memory available for xen.

You can use the command xentop to see the total memory available.

2 Likes

As @renehoj says, the 4GB is a limit on the memory available to dom0. The
remaining memory is allocated to the qubes you run. Qubes actively
allocates memory between qubes.

In most cases 4GB should be fine in dom0, because it isn’t doing much
work.

If you do want to change the maximum allocated to dom0, you can do so
temporarily, by interrupting the boot and editing the boot parameters:
the default parameter is dom0_mem=max:4096M
To make the change permanent, edit /etc/default/grub, change the
option in the GRUB_CMDLINE_XEN_DEFAULT line, and run:
grub2-mkconfig -o /boot/grub2/grub.cfg for Legacy BIOS
grub2-mkconfig -o /boot/efi/EFI/qubes/grubx64.cfg for UEFI

If you want to change the memory allocated to a qube, you can do this
in Qubes Settings, on the “Advanced” tab.
You can also set it using qvm-prefs

Memory management is explained here

I never presume to speak for the Qubes team.


When I comment in the Forum or in the mailing lists I speak for myself.

1 Like

Oh I Didn’t know that. I used to think dom0 shared it’s memory to the other VMs. Thank you for your answer.

Than you unman. It works. :green_heart: