How to hide the fact that I'm Qubes OS from Telegram

Why when I’m using telegram in Whonix 17 Workstation it says my system is Qubes OS, is it possible to change the identifiers? It’s strange that there is no change of identifier for applications like Telegram.

Qubes OS system is for security, but then why is there no way to change the OS identifiers?

Does anyone know how to change the OS identifier?

There are many ways to identify that it’s Qubes OS. You won’t be able to hide everything about it. Telegram knowing that you are using Qubes OS is not a problem in itself, since you are using Whonix, it hides your real IP and most unique identifiers that can link you across activities.

Duplicate of:

Whonix hides my real IP, but in all my telegram accounts it says I’m using Qubes OS, doesn’t look good.

1 Like

Thanks, but I’ve seen this thread, I really didn’t understand what needs to be done, that’s why I created this thread

1 Like

What exactly is wrong with displaying “Qubes OS”? It’s just a name and doesn’t reveal anything unique. Like I said, you can hide that part, but you won’t be able to hide everything that can identify Qubes. If Telegram checks for them, they will know you are using Qubes anyway.

1 Like

For example, not too many people use Qubes OS. Btw thanks for answer and how I can hide this part?

Have you tried this part of the discussion?

1 Like

Yea, I’m just trying right now and testing it.

systemctl --user start wmname.service 
Job for wmname.service failed because the control process exited with error code.
See "systemctl --user status wmname.service" and "journalctl --user -xeu wmname.service" for details.
zsh: exit 1     systemctl --user start wmname.service

systemctl --user status wmname.service
× wmname.service - Change WM name
     Loaded: loaded (/home/user/.config/systemd/user/wmname.service; enabled; p>
     Active: failed (Result: exit-code) since Sun 2023-12-17 22:33:27 UTC; 17s >
    Process: 1981 ExecStart=/usr/bin/xprop -id 0x400002 -format _NET_WM_NAME 8u>
   Main PID: 1981 (code=exited, status=1/FAILURE)
        CPU: 3ms

Dec 17 22:33:27 host systemd[822]: Starting wmname.service - Change WM name...
Dec 17 22:33:27 host xprop[1981]: /usr/bin/xprop:  unable to open display ''
Dec 17 22:33:27 host systemd[822]: wmname.service: Main process exited, code=ex>
Dec 17 22:33:27 host systemd[822]: wmname.service: Failed with result 'exit-cod>
Dec 17 22:33:27 host systemd[822]: Failed to start wmname.service - Change WM n>
lines 1-12/12 (END)
zsh: interrupt  systemctl --user status wmname.service

Can you share what’s in the service file?

In wmname.service

Description=Change WM name

ExecStart=/usr/bin/xprop -id 0x400002 -format _NET_WM_NAME 8u -set _NET_WM_NAME 'dwm'


Replace the Environment line with this:


Reload, start again and test:

systemctl --user daemon-reload
systemctl --user start wmname.service
xprop -id 0x400002 _NET_WM_NAME
1 Like

Yes, that works, thanks, but it still says in telegram that I’m using Qubes OS

Not sure how Telegram works with this, but you may need to re-register the device to update its name.

What do you mean about re-registering my device. Where?

Redoing the device linking steps with the phone.
Also, can’t you rename the device in the desktop app?

I don’t have phone from all my accounts :smiley:
I can rename just device name, but it’s not system version. I’m talkin about system version in telegram


If what you’ve done doesn’t work, I don’t really know what else to do. It looks like the name that Qubes uses for a lot of dependencies in the system. Not sure if there’s an easy way to spoof it without breaking the system.