How to enable UEFI booting

I’m having difficulty installing Qubes via a bootable USB. The problem seems to be that my machine (an Acer Swift 3 laptop) does not support legacy boot mode.

Based on other posts on this forum, I see that Qubes supports UEFI booting. But I can’t figure out how to do this.

in bios, do you disable the secure boot? do you change boot order?

Yes and yes

Do you have a message or something else? Give us more details please…

You just disable secure boot in bios. To install with UEFI just choose the UEFI option when you boot the install ISO from the USB. My computer puts a UEFI tag on some boot options for UEFI sometimes. Usually if CSM is not enabled all the boot options are UEFI by default. This is standard information for most Linux OS and in general for most OS.

That’s what he did…

I’ve disabled secure boot and changed the boot order.

I get the Qubes installation options screen with five options:

  • install Qubes OS
  • test media and install Qubes OS
  • troubleshooting
  • rescue
  • install Qubes OS with latest kernel

I tried all options except rescue, but I go into a loop and end up back at the Qubes installation options screen

The bootable USB must be okay, as I was able to use it to install Qubes on another device

Since you’ve booted into Qubes OS installer GRUB menu then your UEFI booting works.
The reason your PC reboots after choosing the installer GRUB menu option is because of your hardware problems. Search for your hardware on this forum and see possible fixes to this problem.