How to delete pre-installed templateVM fedora-38-xfce after installing fedora-39-xfce? R4.2

Hi, a new Qubes user here :raised_back_of_hand:

I installed fedora-39-xfce as per the recommended option in here:

I updated the template and switched all qubes from fedora-38-xfce to fedora-39-xfce, but when I go to delete fedora-38-xfce in Dom0 terminal as per the instructions in here:

 sudo dnf remove qubes-template-<DISTRO_NAME>-<RELEASE_NUMBER>

I get the message:
No match for argument: qubes-template-fedora-38-xfce
No packages marked for removal.
Dependencies resolved.
Nothing to do.

I then tried the first option, which shouldn’t have worked:

" If the template was originaly created by cloning another template, then you can delete it the same way as you would any other qube. In the Qube Manager, right-click on the template and select Delete qube. (If you’re not sure, you can safely try this method first to see if it works.)"

This method seemed to work, at least the template disappeared from Qube Manager.

Just a sanity check, was it really deleted from the system?

[irrelevant comment retracted]

1 Like

Thank you, fedora-38-xfce is listed as ‘available’ rather than ‘installed’.

No worries, I wrote from memory… not on a Qubes device atm.