How to create a USB qube for use with a USB keyboard

I followed this guide USB qubes | Qubes OS
But I have some issues:
inputs :

sudo qubesctl state.sls qvm.usb-keyboard

outputs :

Summary for local
-------------
Succeeded: 12 (changed=8)
Failed:     1
-------------
Total states run:     13
Total run time:   71.706 s
DOM0 configuration failed, not continuing

What should I do for this issue ?

Did you try to manually set it up?

1 Like

Manually

inputs:


/etc/qubes-rpc/policy/qubes.InputKeyboard

outputs

bash: /etc/qubes-rpc/policy/qubes.InputKeyboard: Permission denied

what is the correct command?

sudo nano /etc/qubes-rpc/policy/qubes.InputKeyboard

1 Like

Is this correct?
The next step …
sudo nano usbcore.authorized_default=0

For qubes 4.1

Oh, and you would probably want to put

sys-usb dom0 allow,user=root

at the top.

1 Like

Please do not check and uncheck posts as solutions if you are unsure.

usbcore.authorized_default=0

goes to the kernel command line as far as I know, but I don’t use it so can’t tell.

1 Like

Sorry it happened by mistake… And thank you for your answers

I think my last question wasn’t clear … According to this guide USB qubes | Qubes OS
I read this note
Qubes 4.1 only: You should also add the usbcore.authorized_default=0 option, which prevents the initialization of non-input devices. (Qubes ships with a USBGuard configuration that allows only input devices when usbcore.authorized_default=0 is set.)

So I edited this command :
sudo nano usbcore.authorized_default=0

If you can help …
Thanks …

If it was for once, but it happened twice and that is why I reacted, because it looks like you are pinging me.

  1. Open the file /etc/default/grub in dom0.
  2. Find the line that begins with GRUB_CMDLINE_LINUX .
  3. Add usbcore.authorized_default=0 to that line, after the word quiet.
  4. Save and close the file.
  5. Run the command grub2-mkconfig -o /boot/grub2/grub.cfg (legacy boot) or grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg (EFI) in dom0.
  6. Reboot.

This is how it should go, but I’m not sure as I said. Please create a backup first, and/or provide an alternative to a USB keyboard (PS/2, or if on a laptop be sure it’s keyboard doesn’t use USB interface but PS/2)

1 Like

I did this too now and everything went smooth. Did it help to you?

1 Like

didn’t work for me… after rebooting can’t find sys-usb