How to create a static IP address when connecting to ethernet


I am having trouble creating an ethernet connection to the qube. I can do it with wireless, but not with manual ethernet connection. In order to connect to ethernet connection I have to assign a static IP and custom dns records.
What I done so far:

  • created an AppVM called Net11 with only network-manager as a service and Provides network option enabled
  • Assign sys-firewall as NetVM to Net11
  • Created a new ethernet connection with static IP and DNS Servers IP inside Net11
  • Assigned Net11 to one of the qubes as NetVM

Fired up Firefox but still no internet connection.

Followed this guide up until the VPN part:

Have I missed something?

1 Like

Set Net11 netvm to (none), sys-firewall netvm to Net11 and one of your qubes netvm as sys-firewall:
Net11 → sys-firewall → testqube

If I set the netvm of Net11 to none the ethernet connection gets dropped

Can you describe it in more details?
How did you configure Net11 and what do you mean by “ethernet connection gets dropped”?
Can you give the logs of this drop?

Name NetVM

zyra-net sys-firewall with Ethernet connection “ZYRAA” provide network
sys-firewall sys-net
work zyra-net

Why are you attaching your network controller to zyra-net connected to sys-net instead of sttaching it to sys-net as should be configured by default?

Because I followed the guide in the link above where the newly created Net11 has the networking set to sys-firewall not sys-net

The guide is about configuring VPN connection in your zyra-net qube, but it’s not saying anywhere that you need to attach your PCI network controllers to zyra-net.

Set Net11 netvm to (none), sys-firewall netvm to Net11 and one of your qubes netvm as sys-firewall:
Net11 → sys-firewall → testqube

So i set the NetVMs as follows
zyra-net —> None
sys-firewall —> zyra-net
work —> sys-firewall

Still no ethernet connection. It shows as disconnected

Did you attach your network controller to zyra-net?
What’s the output of this command in zyra-net terminal?

ip a

it shows
loopback interface

vif5.0 interface

no eth0 interface

But if I connect like in the main post it shows the correct interface and IP address.

Did you attach your network controller to zyra-net in its Devices tab in qube settings?
Also why do you want to use zyra-net instead of default sys-net?

No I did not. How do I do that?

Lets start from the beginning.
What do you want to achieve?

1 Like

Thanks for the patience with this noob that you are talking to :sweat_smile: .

I have the work network that I want to connect but it requires static IP address and is with ethernet.
I want to create a separate NetVM for this kind of connection.
Whenever I fire up the work qube I want to use this connection.

So you want to have your default network connection using wireless connection in sys-net.
And have a separate connection to local network using your ethernet connection in zyra-net.

In this case check your sys-net Devices tab in its qube Settings and remove your PCI ethernet controller from the right column and only leave your wireless controller there.
Set your zyra-net settings to have this configuration in its qube Settings:

  • Basic tab:
    Net qube: (none)
  • Advanced tab:
    Uncheck “Include in memory balancing” in Memory/CPU block
    Set HVM mode in Virtualization block
  • Devices tab:
    Move your ethernet controller from left column to right column


This is done in the qube where the Ethernet controller is, by default it’s sys-net.

When I try to pass the ethernet controller to the right it prevents me.
“ERROR: Devices Tab:
Can’t attach PCI device to VM in pvh mode”