How to change my resolution? Step by Step solutions

Good morning, Qubes community! I recently installed QubesOS and am trying to change the resolution. After installing Qubes OS my only available resolution is 5120x1440 @ 93 Hz.

I originally messed around with the DPI, Scaling, & Font Size to make everything bigger for my poor eyes. However, I thought I read resolution propogates to all the VMs so if I can get that working that would be my best bet.

I am using a Odyssey G9 32:9 and wanted to add a 3840x1080 resolution. I’ve tried the following solutions:

  1. Change with xrandr
gtf 3840 1080 60
xrandr --newmode  "3840x1080_60.00"  345.60  3840 4080 4496 5152  1080 1081 1084 1118  -HSync +Vsync
xrandr --addmode default "3840x1080_60.00"
xrandr --output default --mode "3840x1080_60.00"

Note after this step I see it appear in system tools → Display → Resolution. Once I change it to 3840x1080 it does nothing but asks me if I want to keep the changes. I say yes and it still shows 5120x1440.

I then ran

xrandr --output default --mode "3840x1080_60.00" --verbose
xrandr: Failed to get size of gamma for output default
crtc 0: disable
screen 0: 3840x1080 1016x285 mm  96.00dpi
crtc 0: 3840x1080_60.00  60.00 +0+0 "default"
xrandr: Configure crtc 0 failed
crtc 0: disable
screen 0: revert
crtc 0: revert

I then searched for “xrandr configure crtc 0 failed” errors on google. It recommended finding my correct CRTC number with

xrandr --verbose
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 3840 x 1080, current 5120 x 1440, maximum 5120 x 1440
default connected 5120x1440+0+0 (0x52b) normal (normal) 0mm x 0mm
	Identifier: 0x52a
	Timestamp:  2495194
	Subpixel:   unknown
	CRTC:       0
	CRTCs:      0
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	non-desktop: 0 
		supported: 0, 1
  5120x1440 (0x52b) 685.670MHz *current
        h: width  5120 start    0 end    0 total 5120 skew    0 clock 133.92KHz
        v: height 1440 start    0 end    0 total 1440           clock  93.00Hz

It looks like I have 0 crtcs and I could use some guidance forward. If possible I will edit this initial post with the steps I do going forward to make it easy for people who google search.

Hello and welcome.

Beside the fact we don’t know anything about your system and software versions, the only thing I can suggest is to upgrade to kernel-latest (6.5.6-1). It brought me back my 165Hz refresh rate, and deleted resolutions above 4k my display anyway doesn’t support (I was offered with 8k, tried it and it looked weirdly small).
I had freezes in dom0 with 6.5.5x.

I ran

sudo qubes-dom0-update

restarted my machine. only resolution available is 5120 x 1440. ran the xrandr commands again, but still receiving the “Configure CRTC 0 failed”. I’d be happy to get you any of my system specs, not really a hardware guy so learning how to do that.

I know I have a Nvidia GTX 4090 and not sure if there’s an intel graphics card too.

I think that your topic is the universal secret of a big conspiracy =)

I also encountered a similar problem, I cannot change the resolution inside Linux HVM above the screen resolution of 1920X1080. I tried a bunch of things, just like you created a topic on the forum, but no one could help me.
Interestingly, I previously used Qubes OS 4.1.2 and had no problems with the screen resolution in Linux HVM. I recently installed Qubes OS 4.2.0 and was faced with the fact that it is not possible to change the screen resolution higher than 1920X1080 inside Linux HVM .

So my brother in misfortune tell me which version of Qubes OS are you using?