How to blur video background?


I’m using Q4.0, fully updated. Standard Fedora and Debian templates.

I want to blur the background of my video during Teams conferences. Unfortunately the respective Teams feature seems not to work under Linux.

So, the idea is now to use a v4l2loopback device as described here to do the trick.

Would the following approach work?

  1. install the dependencies in dom0
  2. build the kernel module in dom0
  3. load the v4l2loopback module in the AppVM
  4. attach the physical camera to the AppVM
  5. run the ./deepseg command inside the AppVM and create a virtual video device
    not yet sure where it is coming from
  6. run teams and direct it to the virtual video device instead of the real one

Ok, I could also clone the template and do steps 3 to 5 in the template.

Any tip or idea is highly welcome.

Thx in advance.


Doublecheck your settings. I use MS Teams daily on fedora template and I’m always using background image as “blur”.

EDIT: seems I was remember wrong when I wrote that. Your absolutly right, no such thing currently on linux directly.
I have a windows laptop next to me where I join with the cam, then I have my qubes desktop where I join with my headset, follow presentations etc. Completly forgot about the windows part when I wrote the above :stuck_out_tongue:

I don’t have much experience with this, but I fail to understand why you would have to install anything in dom0 which given the complexity of the dependencies (openCV, V42L, tensorflow)

With this much additional software on dom0 I believe you are largely undermining the security of Qubes OS :warning: for what might be considered a gimmick. Reading the docs, this is not advised.

For example, why wouldn’t this be possible to install solely on an AppVM? In case you haven’t already, I would suggest you try to follow this procedure exclusively on an AppVM (or associated templateVM) and go from there.

Then for installing it in an AppVM it will basically be only a Linux-specific problem, in which case other forums like the arch community may be able to give a few pointers as well.

I won’t be able to help on the specifics, but I just wanted to give my 2 cents.

Best of luck!


There is no menu entry for background effects. Is there any config file where I can configure this?

Thx for pointing the issue with additional SW in dom0 out. I’ll try to compile the module in the respective template.

1 Like

Using the RPM for Teams from Microsoft on a Fedora 32 template there isn’t a ‘background image’ option for me.

Ouch my bad, editing my comment

Bluring video background in Q4 works. Not very stable so far, thought. Havent’t found a way to tell teams to use anything else that the build- in web cam (recognized as USB device, not /dev/videoX).

So far not exactly successful. :frowning: