How to adjust the VM display size to dom0 display size?

Hey

I would like to knw how i could adjust the display size of what the VMs display. I adjusted the panel, icon and text size in dom0, but the size of these things in the VMs are in comparsion really small (as i hope you can see in the picture).

I marked in the picture the areas that are too small so you hopefully understand what i mean.

I guess there should be a general setting for this?

This is not really Qubes related. This is related to the settings of the Display manager/Desktop Environment.
The bottom circle font size is handled by dom0’s DE, yes, but the two other circles font sizes are dependent on other settings.
You should check how to change the font for each app you want to use : start with “Edit->Preferences” for the terminal …
For firefox, google it ^^ There are zillions of topics.

Another way may be to change the setting globally inside each template and/or appVM via the DE “Appearance” preferences, but that depends on the DE you’re using in the templates.

First, open the Settings Manager, select Appearance, select the Fonts tab, and then enable Custom DPI setting at the bottom and set a higher number value. I set my Librem 14 laptop to 156, based on a post I saw here a while ago.

Next, you will need to set a custom DPI setting in each of your TemplateVMs. Here are the commands for debian and fedora TemplateVMs (replace 156 with your custom DPI):

debian:

  • echo -e "Xft.dpi: 156" >> /etc/X11/Xresources/x11-common

fedora:

  • echo -e "Xft.dpi: 156" >> /etc/X11/Xresources

You may also want to configure XTerm for your TemplateVMs as well. Here are my XTerm configuration settings:

debian:

  • echo -e "*selectToClipboard: true\n*faceName: Monospace\n*faceSize: 12\nxterm*Background: black\nxterm*Foreground: green" >> /etc/X11/app-defaults/XTerm

fedora:

  • echo -e "*selectToClipboard: true\n*faceName: Monospace\n*faceSize: 12\nxterm*Background: black\nxterm*Foreground: green" >> /usr/share/X11/app-defaults/XTerm

I hope this is helpful.

I almost forgot to mention that I think you will need to reboot in order for all of these changes to take effect.

Isn’t it better to change the font size rather than the DPI size ?
I honestly dunno the difference between the two, never tried before.
So I just tried and it didn’t update all texts/fonts when using the DPI setting. But I didn’t logout/restart though.
To change the settings of XFCE via GUI, run xfce4-appearance-settings in dom0 or in a domU.

I think that the default DPI setting is intended for a desktop computer with a monitor that is bigger than a laptop. If you just increase the font size while leaving the DPI setting at default, application windows are still too small for me. I do not know of any negatives associated with enabling custom DPI setting, but I would be interested to know if there are any.

As I can recall, customizing DPI in Windows caused too many apps not to display properly (you wouldn’t be able to see menu bar, or buttons in dialog boxes, etc). Obviously poor by design. I’m not sure if it’s the same with Linux, but with that “trauma” on my mind, I always tend to customize each part separately to fit my needs in details.

Ok thanks i will try it out

Thanks. I will try it out

i tired it in a debian template with sudo permission but got the error messages

bash: /etc/X11/Xresources/x11-common: Permission denied

and

bash: /etc/X11/app-defaults/XTerm: Permission denied

I kind of solved it.

i set the screen resolution to 1920x1200. Then i adjusted the sizes of the panel, icons and texts. Now everything fits to each other. Not the perfect solution but good enough for me.

I have not logged in here in a while, and I am sorry for not noticing your reply.

I forgot to mention in my original comment above that those commands need to be run as the root user:

qvm-run -u root --pass-io <debian-qube> 'echo -e "*selectToClipboard: true\n*faceName: Monospace\n*faceSize: 12\nxterm*Background: black\nxterm*Foreground: green" >> /etc/X11/app-defaults/XTerm && echo -e "Xft.dpi: 156" >> /etc/X11/Xresources/x11-common'