How do you open dnf programs on Fedora?

I installed a VPN app that has a GUI via dnf commands in a standalone qube but since the templates don’t seem to have a desktop environment, I don’t know how to search for and open the app. How do we open newly installed apps?

I’ve tried adding them in the qube’s setting but it doesn’t show up (even after restarting) and this command didn’t help either: qvm-sync-appmenus vmname.

I tried following this guide: App menu shortcut troubleshooting | Qubes OS.

Did you change vmname to your VPN qube name? E.g.:

qvm-sync-appmenus sys-vpn

And you need to run this command in dom0 terminal.
You can also do this using GUI: open your sys-vpn qube Settings → Applications tab and press “Refresh Applications”. Then wait for it to finish searching for apps and check the left column and see if “Proton VPN” will show up there.

I had tried the GUI app refresh method but it didn’t work. I then tried your recommendation of the command and got this output:

As I’ve stated in my previous comment, you need to run this command in dom0 terminal, not in sys-vpn terminal.

Also try to run your proton VPN app from sys-net terminal to make sure that it’s installed and works.

I entered the command in dom0 and it went through but didn’t find the VPN app. I also reran the install command and it said that it’s already installed. When I enter “protonvpn -cli” it asks if I wanna install another client so I’ll try typing yes but it’s the old (v3) CLI tool.

I don’t believe the CLI tool receives updates anymore so I’ll wait for Proton Support to tell me where to find the .desktop file and try to set up the WireGuard method in the meantime.

Here’s the tool’s page for reference: How to use the v3 ProtonVPN Linux CLI.

Did you install proton-vpn-gnome-desktop or protonvpn-cli?
Post the steps that you used to install Proton VPN in sys-vpn.

After installing the app, I installed protonvpn-cli.

You can’t have both proton-vpn-gnome-desktop and protonvpn-cli installed at the same time:

If you have the official (v4) Linux app installed on your system, you must first uninstall it. To do this, open a terminal and run the following:

Got it. In either case, if I can’t use V4, then I’ll stick with the WireGuard method until Proton tells me where to find the necessary .desktop file to be able to add its shortcut.

I already installed the Fedora 38 template which natively supports WireGuard and am in the process of updating it. :slight_smile:

I might also stick to using the WireGuard method as the default and keep the app method saved for when needed. The app, although more convenient, only supports OpenVPN.

If you’ve installed proton-vpn-gnome-desktop then desktop file should be in /usr/share/applications/protonvpn-app.desktop.
Make sure that proton-vpn-gnome-desktop is installed in sys-vpn:
dnf list installed | grep proton

Ok so I’ll install the Proton app on the new Fedora 38 template tomorrow.

I’ve been following this guide to switch my disposables and other templates to F38 to delete F37 but don’t understand this instruction “Right click, hover over Template, then click on the new template. Repeat for each disposable template.” I’m hovering over the F37 disposable templates in the start menu but don’t see the option for “New Template.”

Right click, hover over Template, then click on the new template. Repeat for each disposable template.

You need to change Template property in your qubes Setting:
Or you can use Qubes Template Switcher tool.


Alright, the qube settings method worked for just all of the qubes!