How do i set a custom image for my xscreensaver?

I’ve been trying to figure out how to do so within the limits of dom0 (naturally) however i cannot find anything anywhere on the net on how to set a custom screensaver image in Qubes, is it just not possible or am i just missing something obvious?

I think that should be it’s way. There is some lore behind the change of it. The creator is against people changing it and it’s rather non-trivial.

This is the discussion for that on github:

i meant more the image that it displays when it activates (so pretty much to replace the blank screen) for example instead of blanking i’d like it to show me say this image

I see. Then I don’t know. I would assume it’s just a solid color being displayed. So maybe it’s a bit of work. The thing is that xscreensaver has stringent security requirements and anything which does not contribute to the may goal of locking the computer will probably be ignored. You’re better off installing an alternative screenlock assuming physical security is not something you’re concerned about.

I’m setting up my yubikey as a second layer as we speak XD, but yeah probably a good idea. any suggestions for locks? (I haven’t messed with window management etc in a while)

I use the default (even though it’s super ugly). So I don’t know of others. But do keep in mind the fact that if the screen locker isn’t safe, it may just be security theater. For example, some “screen lockers” may crash or be made to crash.

the blank screen is probably for the best since its a laptop (that reminds me to find a way to have non essential qubes suspend when it blanks) and power us always at a premium.

I should note that changing the background color (or any other color) should be relatively easy.

for the life of me i cannot get it to do that either :joy:

xscreensaver is about the best option at the moment.
If you want to change the display, run xscreensaver-demo
(xscreensaver-settings in 4.1), and you can change the display-mode
If you want to use a custom image you can transfer it to dom0 from a
qube using qvm-get-image or qvm-get-tinted-image which will tint the
selected image.
You can also make the image fullscreen in a qube and take a
On the Advanced tab you can select a folder from which to load images.

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

good ol demo mode XD thanks!

i just can’t seem to find/figure out how to.

I did experiment with this a bit, back when I was trying to help you here but I got stuck exactly in the same step.

You should install xscreensaver first.
sudo qubes-dom0-update xscreensaver

then select ‘only one screen saver’
inspect 1 by 1 which one can show your images, i think there’s some.
as example i use starwars opening with text manipulation which print my system information.

Put the images you want to use in a specific folder.
On the Advanced Tab, in the Image Manipulation section, set the image
folder under “Choose Random Image”

xscreensaver has a number of modes that will display and deform images:

Set the mode to Only one screensaver, and select one.

If you want a classic slideshow use GLSlideshow - Select that, and go to
If you set “Always show at least this much of image” at 100%, then you
get a slideshow of the images in the folder you selected.
(If GLSlideshow is not available, you need to install

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.
1 Like

dead end :frowning:

Please explain the problem.

trying to get it to pull from where i have my own screensavers (I.e the ones i made full-screen and screenshot’d) but I’m assuming this is a design limitation so I’m content to use the star wars one running the fortune program. XD

Are you not able to specify that directory? Why not?
There is no limitation (other than access rights).

oh i see what i was missing, there is a text box at the bottom that said images, I thought it meant it was only showing image filetypes but it meant the sub dir that i want it to find XD my bad its working now.