How do I install Flathub Flatpaks on Fedora 38 XFCE?

for some reason i keep get nothing matches or no argument is found even with the flatpak code you told me to put after i install the repository
the flatpak remote-add --user --if-not-exists flathub
code keeps saying no repo found, no match or no argument.

The app name is case sensitive, you need to type the exact name com.jetbrains.PyCharm-Community.
Also on the first image you have an error that you don’t have enough space to install the flatpak. You need to increase the work qube private storage size in the qube Settings.

okay i see i just increased the size of my storage space but look at what i highlighted, i see it showed some already installed stuff like python3, and the qube-apps because i went and downloaded it from micah’s github page… i only downloaded it because i thought it would install that way but it does not run or show in the apps settings screen in no template/or app…

The highlighted text is just the content of the current directory (/home/user) in the terminal.
You can see the same output if you run this command in the terminal to see the files in current directory:

1 Like

okay i do see it now whats the content and what is in home user.
this is whats confusing me its not letting me know anything once i type it how it is with the install the repository code for flatpak remote-add --user look at it .its not telling me no match found, nor is it telling me it’s install… do i need to enable the repository settings first for third party apps ?

As I’ve said before, the app name is case sensitive.
You’re trying to install com.jetbrains.Pycharm-Community flatpak but the correct app name is com.jetbrains.PyCharm-Community.
Notice Pycharm vs PyCharm.

1 Like

thanks i would have kept missing spelling Pycharm- PyCharm wow

You forgot to add --user to the install command. This way the app won’t persist the qube reboot since you’re installing it system-wide.

thank you i got pycharm running but i don’t see it no where in my apps settings screen that’s odd , like to add the application program to my work template .

wow , i forgot user literally :sob: now if i restart my system pycharm is not going to be in my work app/template ?

Press on the “Refresh applications” button in your work qube Settings → Applications tab. Then the flatpak app should be available in the left column.