How do I install Flathub Flatpaks on Fedora 38 XFCE?

so we it --user in between which means not to add sudo correct ?

Yes, run it without sudo.

1 Like

yes, without sudo otherwise it will install for the root user and won’t even persist in the appvm.

1 Like

thank ya’ll so much, 1 more thing is it a difference in results if i completed these steps in dom0 terminal or a fedora template terminal ? i’m also trying to install the qube-apps on micah’s page and for some reason in dom0 i get no results. it keeps saying “no match found for qube-apps” or python3 when i have python3.11 and pips3 installed on my qubes os.

this is the error i keep getting when i tried it in dom0 terminal and my work terminal

You should not use dom0 terminal to install software in qubes.

As for your issue, it seems you need to install the package flatpak in the template to have access to the command flatpak within the qube. I’m surprised it’s not installed by default.

1 Like

to do that would it be from this website right here ?
Third-Party Repositories :: Fedora Docs to install the package flatpak in the templates first?

or are you saying just use the terminal and use sudo apt-get flatpak to install the package ?

You need to install flatpak package in your template, e.g. for fedora template you’ll need to run this command in the fedora template terminal:

sudo dnf install flatpak

Then shutdown template, start you qube based on this template and install the flatpak app in it using flatpak command e.g.:

flatpak remote-add --user --if-not-exists ...
flatpak install --user ...

i keep getting an error and im doing this in the fedora template terminal not the app terminal 1 moment

never mind it worked now i gotta see howto use the second line you typed. thank you sir.

okay here’s the success for the first step which was sudo dnf install flatpak

then here’s the second step i shut down fedora template, then re-started it and look at what it says

You need run the commands in seconds step in app qube based on your fedora template where you want to install the app from flatpak repository.
And there are two separate commands flatpak remote-add to add repository and flatpak install to install app from the repository.

1 Like

do this means it was installed ?and what would the flatpak application say in my apps settings ?

by the way that’s my qube app work.i didn’t use the template terminal fedora

What app do you want to install from flatpak?

thunderbird and im looking for the porcupine app also to set-up an email template vm

also at the top of this page they have a article and link to micah’s qube app that is based on flatpak apps correct? i was trying to install that from his github page

Thunderbird should already be installed in fedora template by default so you don’t need to install it using flatpak.
But in case you still want to install it you need to find the Thunderbird page in flathub:

There you can press Install button and you’ll see the installation instructions:

Manual Install

Make sure you follow the setup guide for your Linux distribution before installing
flatpak install flathub org.mozilla.Thunderbird
flatpak run org.mozilla.Thunderbird

In the " setup guide for your Linux distribution" hyperlink for fedora:

You’ll see that you need to first add the repository.
So first you need to run this command in your work qube to add repository:

flatpak remote-add --user --if-not-exists flathub

Then you need to run this command in your work qube to install Thunderbird there:

flatpak install --user flathub org.mozilla.Thunderbird

okay i see thunderbird now but i have a question about other apps from the flathub apps page… like pycharm for instance i try to install it using the code it says and i get this .

then i want to install other apps from the apps for flathub apps for linux page like pycharm