How do I enable AwesomeWM

I’ve decided to try and make Qubes a bit nicer to use. I’ve seen many references to AwesomeWM so I thought that I’d try that and see if I like it. I ran the qubes-dom0-update command and installed it, however I see no difference. The documentation claims that I should see it as a choice after logging out but I have the same login prompt that I’ve always had with just the username and password. And Qubes still loads up XFCE. Is there something else I need to do to activate it?

If this fails I’ll try KDE but I’m a little worried I’ll hit the same issue if I can’t work this out.

On the login screen look to the top right. There are multiple icons there. One of them likely says “XF” currently. Click it and select the window manager you want to use.


Thanks. This was the answer. I missed it as the top bar is miniscule on a 4K monitor. Qubes really needs to work on its scaling.

I got into AwesomeWM but in its default configuration it is pretty much unuseable so I’ll probably try KDE.

Problems with it include but not limited to;

  1. No logout/poweroff
  2. No settings
  3. Application names in menu prepend the VM name and then truncate so you only see the first couple of letters of the BBC actual application if you’re lucky.
  4. Top bar is miniscule so difficult to use

I’m sure many of these things are configurable but I’m surprised it doesn’t have a half sensible default

AwesomeWM users generally don’t care much about the menu…

Anyway the next version in 4.2 will have the same menu as all the other desktop environments (the new Qubes menu).

1 Like

Qubes OS uses LightDM. You want to look at your /etc/lightdm/lightdm-gtk-greeter.conf file. Especially xft-dpi= :wink:

1 Like

edited – I missed the plot, sorry for the noice.

I look forward to trying it. I’ll see if I can find an expected release date

I’ll look at this. Might be very handy to improve the login screen

You can use the new menu now, you just need to install it manually.

I’m using it in xfce, I’ve not noticed any issues with it.

The new menu looks excellent and exactly what I’m looking for. I can get it to start from the CLI but how do you get the process to start with the system? A systemd script doesn’t seem like the right way. It’s there another kind of autostart system thst I need to add it to?

Does ~/.config/autostart work with AwesomeWM?

That is what I use to run a shell script when I log in, which starts the menu.

I will give it a shot. This new menu actually achieves much of what I wanted in changing window manager so I may just abandon that idea altogether.

So .config/autostart is just a shell script which is run on login?

The file in /autostart needs to be a .desktop file, but the command executed can be a shell script.

You can probably also start the menu from the .desktop file, but I already had a log in script, and I just added the menu to that script.

Thanks. I’ve created the file but for some reason it’s not starting.

[Desktop Entry]
Name=Qubes Menu
Exec=/usr/bin/qubes-app-menu --page 2

Anything look wrong with this?

I don’t know if autostart works with AwesomeWM

Google says this is what you need to use, but I don’t know anthing about AwesomeWM

I’m not currently using AwesomeWM. Just XFCE

In the settings menu, you can use “Session and startup” to select the file.

This was it. For some reason it was picked up but wasn’t enabled.

Does it work in i3 as well? How would I activate it?