How do I actually query for a fedora package in dom0?

I am trying to see the versions of slock, xwallpaper and other various packages’ versions available to dom0 (fedora 32). So far, I have tried dnf info slock, sudo dnf info slock. These return “Curl error (37): Couldn’t read a file:// […]”.

I also tried sudo qubes-dom0-update --action=info slock. This opens up a sys-whonix window and actually retrieves the version info of slock but it flashes on the screen for a split second as the sys-whonix assumes its role completed upon the command execution closing the window before I can discern the version info.

How in the world can I check the available packages to the dom0?

You have different options:

For installed packages what you tried should work.

Otherwise if you want to see info on a package you haven’t installed:

  • keep the VM’s terminal open until you decide to close it:
$ sudo qubes-dom0-update --preserve-terminal --action=info $package
  • show output directly in dom0’s terminal:
$ sudo qubes-dom0-update --console --show-output --action=info $package
3 Likes

Simple

$ sudo dnf list

would give you all installed packages with their version.

1 Like