High Temperature pch_cannonlake-virtual-0

When running ‘sensors’ in a dom0 terminal, the temperature for ‘pch_cannonlake-virtual-0’ is always high, even when completely inactive (i.e. 65C+) and the fans are always running at high-speed.
I’ve confirmed the issue does not occur on other OS’s (e.g. USB boot Pop OS).
Any ideas what could be causing this and how to fix?

Note: Machine is a System76 Darter Pro Laptop

That may be the temp of the north bridge. Mine is showing a static 40C. I’m trying to get the CPU added to the sensor viewer. Some more monitoring info here: CPU temperature sensors in Qubes 4.1 - #2 by Suspicious_Actions

My temperature readings are definitely working correctly. The temperature changes and i can feel the heat coming from the fans.
Is there any way i can throttle down the northbridge?
CPU usage is very low including CPU temps but this northbridge is the one with the major issues, any ideas why?

I’ve done the following on dom0. I think there’s been a slight improvement in temps but if anyone has more ideas it’d be much appreciated!

sudo xenpm get-cpufreq-para
sudo xenpm disable-turbo-mode
sudo xenpm get-cpufreq-para
sudo qubes-dom0-update tlp tlp-rdw
sudo tlp start
sudo tlp bat

1 Like

Seems like this resolved the issue for me. Temps are staying low consistently now.