Hide an AppVM in the menu

I would like to hide completely an AppVM in the new Qubes 4.2 menu. I already removed the applications of this VM with:

qvm-appmenu --remove myAppVM

… but the name is still visible.

1 Like

Sometimes when you remove a VM, Applications Menu entry under that name stubbornly lingers even after a reboot.
In that case, you have to manually remove the .desktop files that contains your VM name in .local/share/applications/

For example, if the VM name is “whatever”, then in dom0

ls ~/.local/share/applications
rm ~/.local/share/applications/org.qubes-os.vm._whatever*

Yep, but here, there is nothing about this VM in ~/.local/share/applications …

You can use qvm-features VMNAME internal 1

You need to reload the menu, or reboot, for the qube to be removed

This also removes it from Qubes Manager, unless you enable show internal qubes.

1 Like

Any way to remove or hide entries within the App menu? I have dvm’s I don’t want to accidentally start. Plus they take up space on the menu. I tried deleting the related applications, desktop-directories and qubes-appmenus files but it didn’t work.

Try look in the places in

~/.gnome/apps

~/.config/menus/applications-merged

~/.local/share/desktop-directories

~/.local/share/qubes-appmenus

My suggestion is just get rid of all the apps shown by opening up Qube Manager → select dvm → right click → Settings → Applications and push them into the left box.

You can also edit the Desktop Entry in desktop-directories by adding NoDisplay=true
but it will only hide from Desktop Menus not from Qubes Application Menu on the top left xfce4-panel.

That’s awesome.

@joe.blough: to remove a DVM template from the appmenu, use this:

qvm-features name_of_your_dvm_template appmenus-dvm

An restart qubes-app-menu (I do killall qubes-app-menu && qubes-app-menu &).

1 Like

That’s what I do but the directory is still there. It helps to prevent accidental starts but it still leaves behind a lot of directories you have to scroll through in the menu.

I even accidentally deleted the entire /.local/share folder (rm -r instead of dir)and that didn’t even remove the directories.

Is there a way to open the apps inside AppVM after making it “internal” through qvm-feature command??

1 Like

You can try to start the apps from dom0 terminal:

qvm-run -q -a --service -- VMNAME qubes.StartApp+xfce4-terminal-emulator
2 Likes