Help with Mullvad using Micah Lee's method

I know that there are other ways to do this, but I have established what works for me. I know that there are other methods but my skills are limited so rather than bug people endlessly with basic questions I’d rather to stick with what works for me.

Some time back I followed Micah Lee’s tutorial here:

I am aware that this is dated and it never worked as Micah intended it to for me but what I ended up with was a standalone VM that did not let other app vms network through it, but I had a dedicated qube that connected perfectly through Mullvad which I used when I needed to use a VPN. It worked, and continues to work perfectly.

This standalone VM is based on Fedora 36 and I never bothered to update it. I have two problems of which I will post just the first here.

I have used Micah Lee’s method with Fedora 39 but when I try to connect to the Mullvad VPN it won’t, and returns errors such as:

The VPN connection failed because the VPN service stopped unexpectedly

This error kicks in usually immediately, occasionally it takes a minute but it won’t connect.

To get the VM to point where you test the connection as above is pretty simple and I can’t see anything that I am doing wrong. Is there any reason why this method that worked beautifully for me before now won’t work on Fedora 39?

Getting this working in this manner is my preferred method as I ran into problems upgrading Fedora 36 which I may ask about separately if I can’t get this working.

I’ll also add that I’ve tried using different templates for the new vm I tried to create with the same error.

Thanks for taking the time to consider.

Hello past me. :rofl:

Qubes R4.2 broke Micah’s tutorial, but it can be fixed. It’s been a while but here’s the thread I made about it:

I had better luck with Debian than Fedora, but IIRC Fedora can be made to work too. With Debian IIRC all you need to do is install the network-manager-openvpn-gnome package and it should work.

Thank you for the reply. I have had success, although not totally.

I checked out the issues related to using Fedora but it just flummoxed me I’m afraid. So I went the Debian route.

I installed the network manager but with this it will not work with Mullvad. It either times out or I get a message telling me that I need to install


From my reading of things this makes no sense and googling didn’t add anything to resolving this. But I am able to use Nord open vpn configs without a problem. With a few tweaks to Micah’s things to accommodate Nord it connects automatically and will reconnect etc.

The one thing that this lacks that my other setup had was that my older setup would not connect to the internet at all unless the vpn was connected which (I think) was due to the firewall rules that I setup that were listed in the Mullvad config. The Nord config provides just the one remote address. If I put this in the firewall rules to limit all outgoing connections to this I get an error saying that there is a failure to parse the gateway ip used by qubes for the vm and nothing will connect, including the Nord vpn. If someone has a suggestion how I can limit the vm in the same way the older does I’d be very pleased to hear how to do it.

So, I have things working on the latest Debian which will be plenty for what I need but if I could get some tips around the firewall rules that would be great.

Again, thanks for taking the time to point me to solutions.