Help needed - Poor performance & freezing on Qubes 4.1

I’ve searched everywhere for a solution to no avail.

Hoping someone in here can set me on the right track. I’ve had VM crash issues & freezing with Qubes. I had Qubes 4.1 installed on an SSD, and tried to install it on a different SSD using the same installation medium & hardware, and had a crash during setup.

When I boot Qubes on my original setup, occasionally, not often, I get freezing during initialization. I can get freezing when the system is left alone without many VM’s open fresh from boot (after some time).

When I open a fedora or debian youtube browser, the tab is quick to crash, and the VM will eventually shutdown if I persist. This also happens on Whonix but less quick. Sometimes if this is done at the same time as opening a different AppVM, the whole system will freeze the screen, and I have to force reboot (pressing power down takes a long time to shut off). VM’s do not take an unusually long time to start.

I’m running a Thhinkpad w530 with HEADS bios, i7-3840QM k1000m dGPU 16GB RAM. Originally the issue was much worse because for some reason Qubes was dynamically sharing the RAM, and so if a Qube had default 4GB RAM it would reserve all that RAM and not share, causing crashes. Reducing the Max ram has made the system somewhat usable, but the lack of ability to watch videos & do anything alike is very limiting.

In ‘top’ when I try to run a youtube video, I am seeing huge spikes in CPU % in webcon+ geckoma+ then tab or VM crash.

Things tried:

  • Adjust RAM allocation
  • Update kernel to latest
  • Update Dom0
  • Reinstall Qubes
  • Install Qubes on different SSD, same hardware
  • Blindly search around Qubes logs for information that might indicate why it is closing.
  • Scour forums for info

Does anyone know how to find logs that might help diagnose the problem? Help is GREATLY appreciated.

1 Like

Looks like your laptop should work fine. Perhaps a problem with Nvidia drivers?

Have others had success in the W530 with the same heads bios version?


Apparently Plexus has :person_shrugging:

@fsflover I’ll look in to that, ty.

Can you help me out and inform me how I boot in to failsafe?

Boot in failsafe

Boot your system using the “failsafe” boot menu, that should have been automatically added to your grub.conf when you installed the Dom0 kernel.

If the X Window System doesn’t start now, this is probably a non-Xen related issue and this guide will probably not help you.

I’m not sure exactly what this means.

With HEADS bios, when I boot Qubes it goes straight to my disk encryption password, no other options RE: qubes pop up.

Systemd rescue?

When you boot Qubes 4,1, don’t you have 2 options listed on a full screen menu before it goes into the prompt for the disk encryption password?

The options should read:

  1. Qubes, with Xen hypervisor
  2. Advanced options

You need to select 2.