Help needed on getting Ledger to work with qubes-whonix

I am trying to get electrum to work with my ledger on whonix workstation using this guide, though every time I try to scan for my ledger, I get a debug message containing multiple ModuleNotFoundError’s, while the udev rules are set up correctly.

I’m also running qubes on an external SSD, so I had to set up sys-usb manually after the installation, which seems to work correctly, since my ledger does show up on whonix workstation (lsusb) after attaching it via Qubes Devices.

Something else I tried was to disable legacy USB support and XHCI pre-boot mode as suggested in the troubleshooting part of the guide. But upon disabling legacy USB support, my external SSD didn’t show up as a boot option anymore.

I’m kind of lost right now, as there isn’t much to be found on the topic. So, any help would be greatly appreciated.

Have you tried setting it up on a Fedora-, Debian-, or Kicksecure-based qube first? If it works on some OSes but not others, that might allow you to narrow down the problem.

Not yet, I’ll give kicksecure a try, since the guide was written with it in mind.

Just tried it on both debian and kicksecure. This time without sys-whonix. Same issue as before.

for testing purposes, I tried to attach a flash drive to the appvm using Qubes Devices and the contents were readable.

I also tried running it on another device with qubes installed on an internal drive. Running into the same issues here.

I attempted it with both a manual installation of electrum and using debian’s package manager.