[Help needed] Installing Qubes--unknown error has occurred

Hi, I’m new to Qubes and have been trying to install it onto my Thinkpad X-230 laptop without success.

Halfway through installation (after clicking “Being installation”) I receive the following error:
“An unknown error has occurred”

I’ve been closely reading the installation guide and the troubleshooting notes read:
“Some people have encountered this error message when trying to install Qubes on drives that already have data on them. The solution is to exit the installer, wipe all data or delete all partitions, then restart the Qubes installation.”

So I loaded a live Fedora OS and wiped the SSD, erasing all partitions. I attempted to format the drive and go through the installation but to no avail, and tried again without having any partitions created before trying to install but still receiving the same message.

I made sure to check that both virtualisation options were enabled in my BIOS.

My install USB is 16GB and each time I’ve ran the Qubes installation I re-flashed the USB with Qubes R4.0.4. I’ve also redownloaded the iso 4 times with the same message appearing from above.

I scanned my USB for any bad blocks but it appears to be completely fine (when using AOMEI Partition Assistant on Win10).

When I used BalenaEtcher to flash my USB, it responded that the flash of Qubes had failed (presumably it had failed the checksum), but it would still allow me to use the install program until it would fail with the message shown above. Using Rufus (& selecting DD image) suggested the flash was a success but I would see the same results of the “unknown error has occurred” halfway through the install process.

I’ve tried both USB 3.0 and USB 2.0 ports for the installation process. I’ve also tried verifying the signature of the ISO with Kleopatra (torrent versions downloaded using qBittorrent) and have received the following message, saying that it could not be verified (message shown in reply since I can only attached one image at the moment).

When verifying the media directly through the install screen, I receive the following message:
“This media is not good to install from.”
Perhaps I should be installing Qubes with a different ISO file from another place.

I’m really at a loss but I feel like this is a good place to ask for help.

Thanks :slight_smile:


  • How you create media installation ?
  • How you configure disk ?


could you try again using rufus as shown in the doc, then just do automatic configure at disk ? would that do ? make sure using latest rufus version.


according to this 1383873 – ValueError: Device 'sdd4' not in tree, there’s a same bug with yours, I believe that soon 4.1 will be stable, if you want you can try 4.1-rc3.

you could find a workaround, but since 4.1 will (maybe 1-2 months) released, familiarize yourself with how qubes works is more important i think.