Help needed in setting up my TP-LINK wifi adapter

WIFI Adapter: TP-WN722N
Qubes OS: R4.1.1

i know bit of linux
i tried running lsusb command but i wasn’t showing anything

I have no idea what i do to get this wifi adapter working

Depending on the revision/chipset used, this may work:

apt install -y iwlwifi

If not, determine the chipset used & install modules or a driver.

do i have run this in one of qubes?

for TP-LINK TL-WN722N v2 and v3 firmware-realtek in sys-net

Well, not really.

Check my answer here: Where to install Wavemon or similar wifi signal strength program - #2 by BEBF738VD

sorry I had not seen it

so my sys-net uses debian-11-dvm and i need to change to debian-11 then install TP-LINK TL-WN722N v2 and v3 driver
i have reinstalled qubes now in lsusb my wifi adapter is showing do i still need to install driver

edit: i have tried installing driver in sys-net but still not showing
(is having sys-usb necessary?, i don’t have one)

Perhaps you didn’t understand my reply.

Install all the drivers in debian-11. Then shutdown debian-11. Finally, restart sys-net.

sys-usb has nothing to do with it.