Help installing Qubes on A1990

Following on Apple Macbook Pro - A1990 and Installing Qubes OS on a 2018 MacBook Pro: Screen goes dark after clicking install which did but resolve – I am trying to install Qubes 4.2 on my A1990 MacBook Pro and am getting the same error screen as the second (“22761”) post, appears to be something from Broadcom. This is not my main machine so I’d be happy to test out whatever advice folks have to get Qubes working. I have an external keyboard and mouse which work.

Hi @barchecker, welcome to the forum!

Any chance you can provide us with more information?

How far into the boot process do you get?

Thanks @alzer89!

I’m installing from an SSD formatted under OSX. I disabled the two boot security features. When I boot the installer from the SSD, I get a text menu with options for type of install. All of the install types quickly move me to the error screen at the bottom of the first post of thread 22761, stating:

setting wl_reg_on to 0 succeeded
setting wl_reg_on to 1 succeeded

At this point the system hangs and USB peripherals are disabled.

Seems like the Xen kernel still thinks there are T2 chip checks, even though you disabled them properly.

Could you try to add noapic to your GRUB paramaters, try to boot with that and see what happens?

If you don’t know how to do this, let me know and I will post step-by-step instructions. :slight_smile:

Thank you. I used that parameter at the end of the first (multiboot2) line. The system showed the same error (wlreg). It then rebooted into MacOS.

I don’t know if it will produce anything useful, but could you try this:


Maybe also:

  • remove quiet (if still pressent) from module2 line
  • add noreboot=1 to the multiboot2 line


I’ve had a go with a MBP A1708 – but that was after the first reboot in the “INITIAL SETUP” … :slight_smile:


1 Like

Ok. It seems to be doing this on quite a lot of the Intel Macs release in the last couple of years.

I’ve had quite a few issues with a few Macs that, on paper, should have no issues whatsoever with booting, let alone running Qubes OS successfully; but they all seem to throw this same error message.

According to a few other Linux distro forums, they suspect that it has something to do with the Apple EFI bootloader and/or the Apple TPM chip/verification process.

We’ll keep trying, but in the meantime, give what @ChrisA suggested, and dump the output of that into this thread (if it’s incredibly long, a screenshot or a photo of your screen clear enough to read it will be OK, too), and we will all do our best to get Qubes OS working for you :slight_smile:

Not great news…I deleted quiet and enabled all of the suggestions from @ChrisA’s comment:

multiboot2 line: loglvl=all guest_loglvl=all vga=,keep

first module2 line: console=hvc0 earlyprintk=xen

And added noreboot=1 to multiboot2

Got the same error as before, just with no restart now. That’s on both the normal install and latest kernel commands.

Hi barchecker

Can you snap a photo of the messages on the screen? – I don’t have the hardware, so I’ve not tried/seen it myself …


Here you go (posterized for privacy)

Did you remove quiet from the GRUB options?


Yes, this is what I was booting with.

Hi Barchecker

Is the following transcript correct for your images?

BCMDHD_ExitBootService: ENTER
dhd_os_wifi_platform_set_power: Setting wl_reg_on to 0 succeeded
dhd_os_wifi_platform_set_power: Setting wl_reg_on to 1 succeeded


setparams 'Install Qubes OS R4.2.0 using kernel-latest (6.6.2-1.qubes.fc37)'
multiboot2 /images/pxeboot/xen.gz console=none noapic loglvl=all gust_loglvl=all vga=,keep noreboot=1
module2 /images/pxeboot/vmlinuz-6.6.2-1.qubes.fc37 inst.repo=hd:LABEL=QUBES-R4-2-0-X86-64 plymouth.ignore-serial-consoles console=hvc0 earlyprintk=xen
module2 /images/pxeboot/initrd-6.6.2-1.qubes.fc37.img


Could you try with:
– I don’t think it changes anything, but just to rule out a typo in the options …

A random google landed me on a page about Fedora and Macs … suggesting adding:

noapic efi=noruntime nomodeset

to the kernel line - can you try that?



Yes, corrected my typo; unfortunately no change.

Did the extra:

on the kernel line change anything?


Sorry, didn’t see your edit in email. I added those and it did not change anything.

Are you attempting a dual boot?

This is booting to the installer USB.

I don’t have a recent Apple.

I am more into trying things rather than knowing things.

What I meant is, If you are willing to devote this computer to only using Qubes?
Do you intend to only boot Qubes?
Do you only have one SSD?

Another Option: Apple used to have a thing called 'Boot Camp" for doing dual boot. Might not work. Qubes can be fussy about being all alone on the computer.

If this is true,you are willing to only end up with Qubes. I would have two USB keys. and proceed this way.

Look at the EFI, and make sure the virtualization is on.

Format the USB keys to FAT32.
Put on one of them, Ubuntu.

Then boot Ubuntu. Install Ubuntu onto Apple laptop.
Nothing but Ubuntu.
I would want to make sure the boot sector on the SSD drive to end up being either MBR, or GRUB2. Which you can set later. Not sure if Apple will tolerate this any way.

Running Ubuntu, I would download a fresh copy of Qubes 4.2.
I might download the Qubes 4.2.1 RC. If this install goes wonky, then try another version of Qubes 4.2.

Perhaps first: Format onto the blank USB using Ubuntu’s internal program, “USB Stick Formatter” to MBR, and FAT 32.
Then onto the second USB install Qubes, using Ubuntu “Image Writer” Qubes 4.2. which ever version you want.

Why would I do it like this, I have had experience that installing Qubes onto the USB, in this fashion can generate an installable version of Qubes 4.2. I tried several options of creating the Qubes USB which clearly did not work. I realize a lot of other folks have had success other ways. Just this worked for me.

Put the Ubuntu USB in, and boot live Ubuntu. From there, use Gparted to Format the drive again, to FAT32 with MBR. I want the drive to be blank. Why? I had problems when the drive had something else on it. Else maybe it is just redundant waste of time.

I also had issues with some hardware if there was a second drive in the same computer, and the second drive had anything on it. I had another experience where the computer would install Qubes onto one drive, when the other drive already had a working OS. and both still worked afterward… ??? I never said this made any sense. I spend hours trying different combinations. so I would hope to prevent you from using up all that time.

Now Boot into the Qubes USB, and see if it will install.
Be warned, there can be points in the install where it seems to hang, when it is - I guess thinking. There was one where there was nothing on the screen but a minus sign. for several minutes.

I would watch to see if the computer seems to overheat.

This is what I discovered by trying things, not by actually knowing why things should work.

Apple Broadcom Wireless adapter, and by default, I think the wired portion of Broadcom, in earlier Apple computers were rumored to “Not” be spoofable. If you think that might be true. then you might use a USB Wireless Adapter.

For what it is worth. Do what you want.


I appreciate the advice! I am going to wait and see if there is more model-specific guidance.