Help Installing LibreOffice

Have been beating my empty head against the wall for a couple of weeks attempting to install LibreOffice.

Have downloaded the LibreOffice file from LibreOffice site. Moved over to the Work/Template file directory. But can not get it to run. Have searched the web for help and no joy. Lots of stuff, but nothing for Qubes/LibreOffice saying:

Step One;
Step Two:
Step Three:

If someone could possible help a feeble brain newbie to Qubes it would be greatly appreciated.

Once I get LibreOffice installed I will be happy to document the process and post on this site where appropriate.

Thank you for your time and assistance,

If it is not urgent, wait a few more days and I will provide you an automated bash script.

If not I can provide you the mandatory steps tomorrow.

In order to install Libreoffice, there are some ways to install it. The first way is CLI, here are the steps to install LibreOffice:

  1. open the qubes that you want to install
    EX: [debian-11] Terminal

  2. use the install command
    EX: sudo apt install libreoffice

  3. once you installed libreoffice, in dom0 terminal, use: qvm-sync-appmenus [your installed qubes template name]

Not safe; most up to date
There is another way is Flatpak. Flatpak is another way to install LibreOffice.
How to install (the flatpak way):

  1. checking if flatpak is installed:
    EX: sudo apt install flatpak

  2. connect your template qubes to a netvm
    EX: debian-11 → sys-firewall

  3. get the flatpak package via the Flathub—An app store and build service for Linux. Then, in CLI use: sudo flatpak install [package]

  4. same as third step from the above method

  5. disconnect the template qube from netvm

  6. create an Appvm for libreoffice and apply

  7. open the libreoffice and use it

If you can use my methods above for your bash commands

This step should not be necessary if you follow these instructions.

Step One:

Delete your “Work” template (you’ve now tainted it by copying whatever you downloaded and didn’t signature verify)

Step Two:

Re-create your “Work” template in dom0 terminal with:

sudo qubesctl state.sls

Step Three:

Clone “Work” template to “My-Work” (or, whatever you prefer)

Step Four:

Start your new “My-Work” template from Qubes Manager

Step Five:

From Qubes Manager, highlight “My-Work” template and click the “Open console in qube” button (upper-right corner)

Step Six:

Login to console as root user

Step Seven:

Install libreoffice from official repository with:

If your template is Debian based:

# apt install libreoffice
# poweroff

If your template is Fedora based:

# dnf install libreoffice
# poweroff

Step Eight:

Create or use an AppVM based on new template & profit

Did you mean ‘Fedora’ in next to last instruction?


I’ve never tried this, but the tooltip for that button states that it’s chiefly for debugging purposes and suggests using a regular terminal instead. I usually execute this sort of command in dom0:

qvm-run -u root <TEMPLATE> xterm

Used it regularly without issue.

+ It’s n00b friendly. IMO sending beginners to dom0 to do CLI work unnecessarily ought be avoided.

Out of curiosity, how do you even use it? When I selected a qube and clicked that button, it started a disposable, then opened (what appears to be) an xterm window with the title sh in that disposable, but I don’t have a command prompt or anything. I can type in the window, but it doesn’t do anything.

It offers a login prompt, I log in, I command.

That doesn’t always work, sometimes you just get the black screen.

Another issue I have with the console option is that the dvm can hang, and when that happens, you can’t restart the qube without getting an error that a volatile image with the same name already exists.

Has never NOT worked for me, YMMV.

I have been successful with installing LibreOffice. I want to thank everyone for their time and responses.

One issue I found was not all the instructions work. My end result was to reinstall Qubes fresh, something I have become very adept at, and do the following:

  1. Download LibreOffice install from LibreOffice site to the untrusted cube.
  2. Copy the Work cube to create a new cube
  3. Using the File Manager, copy the LibreOffice download to the new cube template directory
  4. Unzip the zipped install files.
    5 Run “sudo dnf install LibreOffice”. Fedora cube. This is something I tried previously by would not install.
  5. Shut down and restarted Qubes.
  6. Using the App Manager selected and added LibreOffice to the new cube.
  7. Shut down and restart the new cube. All is golden in cyber land, LibreOffice showed up.
  8. Took the dogs for a walk in the fresh snow.

I have been successful with installing LibreOffice. I want to thank you for your time and response.

I want to thank you for your time and response. I have been successful with installing LibreOffice.