Help installing display link in dom0

Objective- achieve installation of display link and connect my dock to qubes to have different qubes running on different monitors.
Procedure tried- 1. Display link provides their drivers as a .run file and i downloaded it and moved it to dom0 but executing it gave errors.
2. Came across the display link rpm github repo GitHub - displaylink-rpm/displaylink-rpm: RPM sources for the DisplayLink USB display adapters
and downloaded the rpm moved it to dom0 then chmod +x rpm file and sudo dnf install rpmfile
But it gave me an error
" Nothing provides dkms needed by display link, try to add --allowerasing to command line to replace conflicting packages"
so i did qubes-dom0-update dkms
then again tried to install the rpm.
3. Then rpm installed and i got an error with displaylink service, apparently the module evdi is not found, in module directory and i dont know how to install it.
Though i did try unraring the module file and just copying it to the said directory of modules which changed the error from module evid not found to execstartpre=/sbin/modprobe/ evdi failing.
Can anyone tell me how to install this evid module???

Just adding here the usual security disclaimer over installing software in dom0 (for anyone else seeing this thread).

:warning: Security disclaimer

Since software running in dom0 can potentially exercise full control over the system, it is important to install only trusted software in dom0. Read more »

yea i know, do u know how to install the evdi module though?

Here’s how I approach this sort of issue for code for dom0.

Create a Fedora-25 qube, preferably as a standalone (it’s just easier).
You can do this by using a Fedora-25 installer or by using a Fedora-25
template and then create a standalone based on that.
In your case you don’t need to apply any qubes dom0 packages.

Make sure that your new qube is online and the repositories are pointing
to archives, where the outdated Fedora-25 packages are now stored.
Install development tools.
Build the package in your fedora-25 qube.
Transfer it into dom0.
Run a local install of the new package.

If there are dependency errors you can resolve these by
qubes-dom0-update on the dependencies.

I don’t know if this will work in your case, and I would not do this if
you only have one Qubes install.
Take an old disk, do a base install of Qubes on it, and keep it for
testing. You can save yourself all sorts of trouble by doing this. (If
you are going to do this a lot, install Qubes in a smallish partition,
and image it on to another partition - then you have a simple test
bench, and can easily recover from errors.)

this is what i did bro, and i successfully installed the display link package, then issue came with evdi module. And i cannot figure out how to install it. I cloned and evdi repo and tried to run make, but that did not build successfully and gave me an error.
If you can test this or help me out, it would be great!