(Heads) laptop doesnt turn on


I have a Lenovo thinkpad T430 with coreboot and heads.
After changing my password and “forgetting” it, I had to reinstall qubes but without success, so I decided to update heads to 1.3.1, unfortunately directly after flashing was “succesful” the laptop shut down and it doesnt turn on anymore. Any suggestion what happened? What I have to do now?

Someone an idea?

Do I need to reflash?

German is not my language, but this might be relevant:

Let me ask: what was the heads version you had, and what was the version you flashed? Did you build it yourself?
My gess is you flashed a *-maximized version internally (from the heads gui). If that was the case, now the only solution is to flash externally.

Thank you for the answers guys, I didnt flash the maximized I tried to flash 1.3.1 intern.

I flashed heads extern now, it was a hustle but works again

I guess, it is the same issue as:

Let’s see if Nitrokey support can fix it.

No I had another issue, maybe I didnt explain it well sorry

I hope you opted for the maximized version. I would recomend it. Probably non-maximized version wil be deprecated.

No, but most definately I will update to maximized soon

Why do you believe that the non-maximized version will be deprecated? I think it is better idea to repeat what Nitrokey team says: it is not recommended to use the maximized version.

What I have been observing is that It is increasingly difficult to maintain, specially because of flash memory constrains. There are some contributors sugesting this, but I do not have more info than github issues. (Not sure, but i think they already have to drop the graphical user interface in order to support Qubes 4.1 instalation)
I suggested it because you were already flashing externally, wich is mandatory for *-maximized.
My guess is that nitrokey team is trying to avoid the problems that will (surely) arise if less capable users start trying to flash externaly themselves (probably their use base is largely folks who do not want to deal with that stuff).

The official Nitropad upgrade (ref. Feb. 23rd, 2022) is not correct:

You need to download the npf first unpack it and afterwards boot from the rom (which is insight the npf). See:

@Username001 did you manage it?

Yes everything works now