Headphones via 3.5mm headphone jack not detected

I’m using headphones connected directly to the front headphone jack of an Intel NUC 11th gen.

I’ve used the same headphones with the same cord on Qubes on my laptop and it works.

I have looked through the sound configuration settings to look for an available device but nothing except my monitor shows up. There is no option for headphones or even headset.

I could plug in the headphones to the monitor, but I’ve done that and there’s a slight buzz sound, which I’m pretty sure is a fault of the monitor itself (despite being pretty high end and fairly new).

I looked through the BIOS and there are some options that may or may not be causing it, such as DSP, HD Audio and some other options. The issue is not with the NUC itself as I’ve used Windows on it and the audio works with the same BIOS settings.

EDIT: I found this article. I found one pci device that says “Audio device” and I followed the instructions with that as the target pci device, however I get the following error: Got empty response from qubesd. See journalctl in dom0 for details. I entered “journalctl” in dom0 and got a bunch of logs that I can’t decipher.

EDIT: I discovered there’s a way of doing this through the GUI via Devices in qube manager (I remember seeing this tab but forgot about it). However, I still didn’t hear audio at first. What ended up working was going to the volume settings > Configuration, and selecting Analog Stereo Output, which, confusingly, says (unplugged) and (unavailable). I go to the Output tab, and next to Port it says Headphones (unplugged). Despite this I’m getting sound. What the hell?

1 Like

Thank you @88uhbvpqboufpcez for sharing your experience!

I see that you updated the above post. Some people, including some core developers, are interacting with this forum via email. They do not receive the edits made after 10 minutes. For this reason, it’s better to make a new post, not update the old one (and/or use quotations like I do here):


I see. Sorry about that.

1 Like