HCL Zephyrus G14 GA402RJ_GA402RJ

Here is the HCL yaml:

brand: |
model: |
ROG Zephyrus G14 GA402RJ_GA402RJ
bios: |
cpu: |
AMD Ryzen 9 6900HS with Radeon Graphics
cpu-short: |
chipset: |
Advanced Micro Devices, Inc. [AMD] Device [1022:14b5] (rev 01)
chipset-short: |
gpu: |
Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:73ef] (rev c2) (prog-if 00 [VGA controller])
Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:1681] (rev c7) (prog-if 00 [VGA controller])
gpu-short: |
network: |
MEDIATEK Corp. Device 0616
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |


add x2apic=false to end of first line in grub that starts with multiboot2 to launch installer without error

for first boot:
add x2apic=false to end of multiboot2 line in grub option
At config screen on first boot unselect USB qube. Otherwise config hangs on configuring the network.

to make it so I don’t have to edit and add x2apic=false to grub on every boot:
edit /etc/default/grub in dom0
add x2apic=false to end of line starting with GRUB_CMDLINE_XEN_DEFAULT
put inside of quotes
grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg

to get USB working:
create usb qube (sys-usb) after install by running this as root in dom0
qubesctl state.sls qvm.sys-usb
created sys-usb qube with added usb pci devices
remove device 7 all together (dom0:07_00.x)

to get wifi working:
must upgrade to kernel 6.x to use wifi. It’s not in mainstream stable release
to check available kernel updates from the qubes-dom0-unstable repo run:
[user@dom0 ~]$ sudo qubes-dom0-update --enablerepo=qubes-dom0-unstable --action=list kernel-latest-qubes-vm
then install with:
[user@dom0 ~]$ sudo qubes-dom0-update --enablerepo=qubes-dom0-unstable kernel-latest-qubes-vm
change kernel of sys-net in advanced settings, and rebooted whole machine (dom0)

get control over CPU and GPU fans because it runs hot


Thank you @wahcha for your HCL report, which is online now!

1 Like

Thank you!

1 Like

@Sven The HCL report you posted lists RX 6650 XT as the graphics card in this laptop, but I think I have the Radeon RX 6700S. Can you please update the listing?

1 Like

@wahcha I usually check the device id’s against devicehunt…

But I see that Asus lists the Radeon RX 6700S on their product page.

Searching for it I found 1002:73df = Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M], but that’s not an exact match. Finally a Google search for “Radeon RX 6700S” “VEN” “DEV” “1002” reveals that indeed according to deviceinbox.com and driverslab.ru the ‘73EF’ device id is also applied to the ‘RX 6700S’.

So I changed the HCL report. Thanks for pointing it out!

Thank you!

I don’t understand what you’re doing here (I’m trying to do the same thing on the same laptop)


Is this placed into the quotes?

Also, what is this in reference to:

grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg

Also, can you clarify the steps to get USB working, as well?

You’ve definitely helped point people in the right direction and I appreciate your trailblazing.

Just regarding install and first boot, press e at the installer grub menu and add x2apic=false to the end of the line that starts with multiboot2. You don’t need any quotes. Then press F10 to boot that command. Proceed through the installer as usual. Then when it comes time to reboot, press e on the grub menu again and add x2apic=false to the end of the multiboot2 line. Again, there are no quotes. Put it after the closing curly bracket. When greeted with the config screen, unselect the USB qube and proceed. That should get you a working system, but you have to edit the grub menu on every boot.

Don’t worry about the

grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg

command or the usb qube until you get the system running.

The credit goes to @Irvick for discovered the x2apic=false setting. I learned about it here:

I couldn’t figure out a software fix for the CPU and GPU fans. They were stuck at 5% even when the temps got up to 85C. I cut the blue wires, so now they’re at 100% all the time. It’s not ideal, but I’d rather have them stuck on at 100% than 5%. Now temps hover around 35-40C at idle which seems pretty reasonable to me.

I also disabled the dedicated GPU. The screen was flickering when I tried to use it. Now that it’s disabled, power consumption and temperatures are more reasonable. I didn’t notice any improved performance using the dedicated GPU anyway.